PhpStorm 2018.1.4 CLI debugging breaks but won't map to filenames

Answered

I'm running PhpStorm on a linux box directly, with the target code running in a Vagrant box (running Debian).

When debugging web calls through nginx+fpm, it works properly. When running CLI files, I get the prompt telling me that /vagrant/myfile.php cannot be found locally, to set PHP_IDE_CONFIG blah blah.

It will hit every breakpoints I set, I can inspect variables, it just won't map any files.

This used to work before upgrading to Kubuntu 18.04, which may or may not be related. I tried upgrading from 2017.2 to 2018.1.4, which did not help.

I can debug fine with the same Vagrant box on my Windows 10 host.

4 comments

> to set PHP_IDE_CONFIG blah blah

Did you do that?

There were some changes in CLI debugging so I would suggest to run through our updated guide & set CLI debugging from the scratch: https://confluence.jetbrains.com/display/PhpStorm/Debugging+PHP+CLI+scripts+with+PhpStorm

0

I did, I set it to PHP_IDE_CONFIG="serverName=localhost" in an attempt to match what my PhpStorm settings are.

 

0

So you have File | Settings | Languages & Frameworks | PHP | Servers > localhost entry, correct?

What are the mappings there? Did you try to set that manually?

0

I finally got it to work again. I deleted my localhost entry, created it anew, and I entered the following host IP (same as under Windows): 10.0.2.15, port 22.

Looks like that was the ticket. Oddly enough on Windows it looks to be a lot more automatic.

 

 

0

Please sign in to leave a comment.