Remove project after adding it to an existing project


I did search the form and look into each menu of phpStrom, but I was not able to find out how to remove a project, that was added to an existing project.

Could anybody give me a hint?


What I did:

1. Opened a project

2. Then: File -> Open to select another project 

3. Upon asking where to open it, I chose "in current window" and "append to existing project" (or similar ... writing from memory...)


Hi there,

Just focus that project node in the Project View panel and hit Delete (or right click and "Remove from Project View)

Permanently deleted user

Thanks, Andriy! :-)

It is quite an adventure to find the right node, when the domains consist of lots of dots like

Seems that I should adapt my way of writing local testdomains :-)



Hopping onto the same question, why do I not get the option to remove a project from the project view? I only get the option to physically delete the project instead.

This is on Windows 10 and PhpStorm 2018.3, btw.


Are you clicking on a top-most project? You can't remove it from a project view because it's a "parent" or "main" project. 


No, I am not. Clicking on the top-most one doesn't give me any delete option. I had to manually delete the <module... entry in modules.xml to get rid of it again.


Confirmed - ran into exaclty the same issue. 

Main project open -> open another project -> attach -> when clicking on *attached project folder* in projects tool window only *delete* is available.

My observations - the attached project was already created before as the main in PhpStorm. When I create a new folder and attach it, the *remove project from view* does show up.

For now, only manual removal from modules.xml is the way to go.  


My observations - the attached project was already created before as the main in PhpStorm. When I create a new folder and attach it, the remove project from view does show up.

This issue comes up every now and then, but we can't reproduce it locally, and no one stayed with us long enough to help us out on that.

Is there a stable way you can reproduce this? For instance, if you remove modules.xml and then attach the same project, would the menu item show up?


I'm facing the same issue.
Also, not sure if it's related, from time to time, when I'm trying to open just one projects it opens the view with other projects.

So I believe it's somehow related to the way how view configs are stored.

I would like to help with further investigation, but need to strict instructions.
For instance, where can I find "modules.xml"?


Found modules.xml
<?xml version="1.0" encoding="UTF-8"?>
2 │ <project version="4">
3 │ <component name="ProjectModuleManager">
4 │ <modules>
5 │ <module fileurl="file://$PROJECT_DIR$/.idea/common-header.iml" filepath="$PROJECT_DIR$/.idea/common-header.iml" />
6 │ <module fileurl="file://$PROJECT_DIR$/../cwf-1-new-splash/.idea/cwf-1-new-splash.iml" filepath="$PROJECT_DIR$/../cwf-1-new-
│ splash/.idea/cwf-1-new-splash.iml" />
7 │ <module fileurl="file://$PROJECT_DIR$/../cwf-product-config-webdev/.idea/cwf-product-config-webdev.iml" filepath="$PROJECT_
│ DIR$/../cwf-product-config-webdev/.idea/cwf-product-config-webdev.iml" />
8 │ </modules>
9 │ </component>
10 │ </project>

Remove button was not available, but backspace did removal from project view.


Yadmitriy what IDE version are you using? We have reports that this problem no longer occurs in version 2019.3.1.

If you're on that version and still affected - please attach the project's /.idea folder archived in a comment to You can set visibility of the attachment to "idea-developers" or similar


Same problem here in PyCharm. I was having this issue for a couple of days. Here is my about section (licensed removed for privacy reason):

PyCharm 2019.3.4 (Professional Edition)
Build #PY-193.6911.25, built on March 18, 2020
Runtime version: 11.0.6+8-b520.43 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 5.3.0-45-generic
Non-Bundled Plugins: NodeJS, String Manipulation, com.jetbrains.plugins.jade, com.ppolivka.gitlabprojects, mobi.hsz.idea.gitignore, name.kropp.intellij.makefile, org.jetbrains.plugins.node-remote-interpreter, org.jetbrains.plugins.vue, ru.adelf.idea.dotenv, ru.meanmail.plugin.requirements
SO: Ubuntu 18.04.


mrroot5 please attach the project's /.idea folder archived in a comment to You can set visibility of the attachment to "idea-developers" or similar


I 'm sorry but this project isn't mine, any data about it couldn't be share. If you need something more specifict I could try to offusc names. If this is not possible I need to ask permission to share it.


Basically, the ".idea" directories should be enough, there is no need to upload any part of your codebase.

Also, you may change comment/attachment visibility settings to "PhpStorm Team" to make these private. 


The ".idea" directories contains information about proyect, directories and file names of my project. Not only codebase is important. That is the reason because I couldn't give you that information. I will try to offusc that information and upload it for phpstorm team.





I met the same issue in PhpStorm 2020.2.

I've created the issue

I hope you can find the reason.


The same issue still persists in ver 2021.3.1 

I have to go through the .idea/modules.xml file and manually delete the project entry.


Is it reproducible for you reliably? If it is - it would be great if you could submit this to our tracker at


I have what sounds like this problem in IntelliJ 2023.1.

Can't see how to remove the second one.


Things with projects are bit different in the IntelliJ IDEA.
Please check what you have in "File > Project Structure > Module" first.


The second project that I want to remove does not appear among the modules in Project Settings.

This is a Flutter project, so it has within it Android and iOS project file structures. Weirdly, the Android folder appears among the modules and as a project at the top level of the Project pane, and I wouldn’t mind getting rid of that without deleting the files either.
Can I delete the Android entry in the Project Settings without losing the files?

I'm encountering the same issue: I'm unable to remove the second project that was recently attached. 
phpstorm 2023


We can't reproduce the issue, no matter how hard we tried - I even tried using a customer's config, caches, and projects, and still, the button was there for me. It must be some kind of a race condition or something.

Kapreski, as a workaround, please remove the .idea folder from the carrier project while it's closed - your settings will be lost, but at least you'll get rid of the attached project.

Or, you can just open the .idea/modules.xml file and remove the module manually.


Eugene Morozov I was able to remove the project  without deleting the .idea folder by following Yadmitriy 's suggestion and editing the modules.xml file within the .idea folder.


Please sign in to leave a comment.