No tooltips whatsoever when viewing Typescript and Javascript files. Is this default behavior?

I'm loving the refactoring capabilities of this IDE when using Typescript with Angular but when I'm viewing a typescript file, I get can't a single tooltip to show for anything in the code file. 

I can hover over types, methods, local variables, you name it. No matter if I click them first or keep the mouse over them for 30 seconds, nothing ever appears.

I'm so used to Visual Studio where there are tooltips for practically everything. Please tell me I accidentally disabled something when I was initially configuring Webstorm.

 

Thanks in advance! 

1
26 comments

No tooltips are shown on mouse hover by default. You can hold Ctrl while hovering to see the declaration +  inferred type; to see quick docs onouse hover, try enabling Show quick documentarion on mouse move in Settings | Editor | General.

Tips: Ctrl+Q allows to view quick documentation, Ctrl+Shift+I - quick definition, Ctrl+P - parameters info. Ctrl+click/Ctrl+B allow navigating to declaration. see actions in View and Navigate main menus for more

6

stopped working for me with new update  2022.2 ?  kinda annoying 

1

Igor Pavlenko if th issue persists after caches invalidation, please share screenshots illustrating it

0

Elena Pogorelova I did https://www.jetbrains.com/help/webstorm/invalidate-caches.html with all checkboxes 
no change, plz check the screen when hover over nothing appears ? 

attached also VScode for comparison


0

what is a result of ctrl+hovering on auth?

0

im using mac but both cmd+hov | ctrl + hov show nothing 

0

what is a result of Navigate > Declaration and View > Quick Documentation?

0

don't have "Declaration" option 


0

it's called Declaration or Usage

0

Declaration or Usage works but what i m missing is display variable "TS type" ? i shared VS code screen earlier for what i mean and need ? 

0

Does View > Quick Documentation work? Also, what shortcuts are assigned to Main Menu | Navigate | Go to Declaration or Usages in Preferences | Keymap?

0

any solution ? this is quite inconvenient ? 

0

No idea... Could you check if you can reproduce the issue if you start the IDE with default settings (File > Manage IDE Settings > Restore Default Settings...)?

0

followed your instruction but no change ?

0

is the issue specific to certain files/code constructions, or Cmd+hover tooltips don't appear at all? can you reproduce the issue in a new project?

0

Hi,

I think I've got a similar Problem. Just updated to 2022.2 on my macbook (m1) and not getting any quick documentation on mouse over. 

First at all I cannot find the "Show quick documentarion on mouse move" in Settings | Editor | General. Should it be beneath Mouse Control settings? When I search "quick" in settings the Editor | Code Editing seems to have some results but no setting is highlighted.

When I try to set it in the quick documentation popover (opened via shortcut F1) | three dots | Show on mouse move it does not change anything and checkmark is not shown.

1

@Silvan S.

Settings/Preferences | Editor | Code Editing

If you are unable to locate "Show quick documentation on mouse move" option in the IDE settings, then check the links in the following comment:

https://intellij-support.jetbrains.com/hc/en-us/community/posts/4414191199634/comments/5018263891858

2

Elena Pogorelova any solution, I tries all you suggested but no luck ? 

0

@Andriy Ok well the the solution in the link helped. Thank you

0

Hello everybody, did someone found a solution for this? I'm having the same issue on my MacBook Pro m1 and MacBook Air m1, both with different typescript projects. Thanks.

 
0

I was able to show the type definition by clicking the Interface/type and then pressing option + space (see images) but I'd like to show this when I hover the functions/variables. Any ideas?

0

Quick Definition is not available on mouse hovering; see https://youtrack.jetbrains.com/issue/IDEABKL-5345.

0

If Quick Definition is not available with mouse hover, how can we replicate the VScode behavior that Igor Pavlenko mentioned on his comment, Elena Pogorelova?

0

Please try Ctrl+hover; you can also try enabling  Show quick documentation on hover in Settings | Editor | Code Editing as suggested above (https://intellij-support.jetbrains.com/hc/en-us/community/posts/360000590764/comments/7128307464210)

0

Please sign in to leave a comment.