Apache Server v2433 Running Configuration


Dear Support,


I would like to create a "Run/Debug Configuration" for my local "Apache Server" (not Apache Tomcat)... 


When trying to create a new configuration, I can see many options (i.e. Tomcat Server, Cold Fusion, Flash App etc), but nothing on (Apache HTTP) server whatsoever. 


I would appreciate if you could please let me know if there is an option to enable this, or if you already have it but under a different name than (Apache HTTP Server). 


Thanks & Regards




These run/debug configurations are only for Web Application servers that support Java EE applications, not plain web apps with HTML/JS.

If you are working with the plain static web project, refer to https://www.jetbrains.com/help/webstorm/deploying-applications.html.


Hi Serge


Thank you your reply, the project is not a static/HTML, but rather a PHP project that I need to run on Apache, I was surprised to see so many options to cover (WebSphere Server, WebLogic, Tomcat etc) but nothing on (Apache HTTP server).

Previously I used to work Tomcat server (via the Java-PHP-Bridge), as I do also have J2EE content. But that doesn't always work since the PHP_AUTO headers does not get passed trough.

Therefore, the only option I have right now is to deploy my PHP content on my Apache server which is used in production. 

I set up the deployment fine, but cannot find any (run/configuration) to run the code on an Apache-Server (as a whole project, not just a single PHP page).


I wonder if the option to support Apache-HTTP-Server is there but named differently, or if there is a specific plugin I need to install, or something else.


I tried to create a configuration also under Tomcat-Local server, but when I create (New i.e. the "...") to get the server in, it says "The directory you specified is not a Tomcat server directory" which is correct, so, I am looking to enable my Apache-HTTP server this way.


I would appreciate your help.


Many thanks


In other words, the only servers from the list I can see are below.

I can't find anything for Apache HTTP server, which I am looking for.







Hi Serge,


Thank you for getting back to me, I will go through the details you sent shortly.


I noticed however that the link you sent is about PHPStorm, however, the question I have is for IntelliJ Idea.


I think they are very similar, will try to go through your link soon anyway.


Thanks again




Hi Serge.


I tried your link, unfortunately, it foes not resolve the problem for the following reasons:

1) The link was meant for PHP Storm, however, the question was for IntelliJ. Even though the configuration might look similar, however, under IntelliJ (Test Frameworks) there is only one item when clicking on + which is "Local (Current Project)" which does not help. 

2) I also tried your link on PHP Storm as well, however, under (Test Frameworks) I can see the list of (PHP Unit Local/Remote, BeHat Local/Remote, etc), I click on "PHP Unit by remote.." as per your article, but then I see "No Interpreter" (see screenshot attached). I try to create an interpreter by clicking on "..." but then all settings inside are correct and still can't create it.


Therefore, with that, unfortunately, the link you provided does not help resolving the issue I'm afraid.


I am trying something else that it might work, and will add the solution here shortly if it does. 


Kind Regards




I finally resolved the issue.

IntelliJ does not have "Apache HTTP Server", could be unsupported or no plugins have been made for it so far.. the solution is to do the settings indirectly and let it serve the web content from the project DIR instead. 

1) In IntelliJ, create your project, make sure your web content (i.e. the docroot content is placed in a "web" directory for example) i.e. make sure that your MyPage.php is located inside a "web" folder... 

2) On apache, create a Virtual Host, set it's DocRoot to be at the "web" directory from step-1 above, also set it to listen on "myweb.local", use a port say; 8080

3) Power up the apache server, you should be able to browse into the content of your IntelliJ project (http://myweb.local:8080/MyPage.php)

4) In IntelliJ, Goto "Run/Debug Configuration", click "+" and select "PHP Web Page"

5) Under "Configuration" ... click on "..." from the server-list this will take you into "Servers" 

6) click "+" to create a new server, enter MyWeb, and then MyWeb.local into the Host, and 8080 into the port, and XDebug into the debugger (I use XDebug), use whatever you like otherwise. Click Apply and Ok... 

7) Select the new server you create into the Server-List 

8) Enter /web/MyPage.php into the Start-URL

9) Select your browser to be whatever you like, I use Safari at the moment. Click Apply/Ok. 



Now, setup the Deployment to use your local FS as follows:


1) Go to Tools -> Deployment -> Configuration 

2) Click "+" to add a new item

3) Select "In Place" from the list, and call it "Local In Place"

4) Enter http://myweb.local:8080 in the Web Server Root URL

5) Select the Mappings tab

6) On your Local Path, enter (...YourProjectFolder...)/web

7) Enter "/" for (Web Path On Your Server)

8) Click on "Use This Server as a default" in case it's highlighted. 

9) OK.


No Testing...


Setup a breakpoint on any of your PHP pages, click Debug, it should break there...


I hope this helps.



Heider Sati



Please sign in to leave a comment.