IDE Settings not synced

Answered

I am trying to use jetbrains account settings sync feature but it doesn't sync with PhpStorm. Initially I created the settings in IntelliJ Idea Ultimate. I also tried exporting and importing settings but it also doesn't work.

Not sure if this is intentional but importing settings between PyCharm Professional and IntelliJ Idea Ultimate worked fine, so I was sure this feature is for all IDEs.

Update: Can confirm that when installing PyCharm Professional and enabling sync settings, settings synced. CLion on the other hand has same issue as PhpStorm.

Shall I file an issue?

22 comments
Comment actions Permalink

Same to me((( The plug-in shows that it works, but settings reseted to defaults when starting phpstorm((((

0
Comment actions Permalink

Yeah, if I understood correctly sync only works between same IDE's i.e. PhpStorm <> PhpStorm, PyCharm <-> PyCharm. It's a shame, was looking forwards having synced settings between all IDE's :)

0
Comment actions Permalink

I have phpstorm only. Maybe I do something wrong, but there not a lot of settings. I just turn plugin on, and thats it, phpstorm restarts, and settings are sets to default. ((((

0
Avatar
Vladimir Luchansky
Comment actions Permalink

Hello,

Do you use settings synchronization via JetBrains account or via Git Settings Repository?

IDE Settings Sync via JetBrains account doesn't support different products at the moment while Settings Repository might solve this for you: https://www.jetbrains.com/help/phpstorm/sharing-your-ide-settings.html .

0
Comment actions Permalink

I think i get it. Can I sync only settings that set in File->Default Settings via JetBrains account...?

If I want to sync live templates, I need to use settings repository?

0
Avatar
Vladimir Luchansky
Comment actions Permalink

No, Live Templates are also synchronized via JetBrains account. Were they not synced?

0
Comment actions Permalink

Yeah, I think they are. I deleted all sync settings in both installations and now it seems work.

0
Comment actions Permalink

I'm having the same issue, it looks a bit flaky. I wanted to switch from git to jetbrains settings sync. But when I've disabled the git sync, settings were reset to default. I've reenabled the git sync, got my settings back and exported to a jar. Checked its contents and keymap and live templates files inside it did not contain my custom settings, even though they are present and working in the IDE atm. I'll keep using settings repository for now, but I would really like to make the switch to jetbrains account settings sync.

0
Comment actions Permalink

I can confirm the issue that Thiago described.

After switching from Settings Repository(I used Bitbucket git repo) to Jetbrains Settings cloud sync all my custom live templates were gone! Luckily I still have that settings repo so I had to switch back.

How can I switch to Jetbrains Settings method so that I don't have to re-create all my live templates?

0
Comment actions Permalink

Same here - coming from git settings repo: 

Exported all settings to jar

Removed settings repo sync

Imported settings jar

Everything is default - nothing imported from settings.jar.

 

So I cant move my settings from repo to jetbrains account

1
Comment actions Permalink

I would not advice using this service, it works so randomly. I actually bought the product since I was sure this will finally be the answer to synced settings on my linux working environment. Sometimes it randomly semi resets the settings, sometimes it doesn't take my last settings etc.

1
Comment actions Permalink

Michael Naab, it's a known issue. To work that around, you can move your config back from config/settingsRepository/repository:

  • Files in this directory go to config/options.
  • Contents of folders starting with _ also go to config/options.
  • The rest of the folders go to config.

It's strongly advised that you backup the whole config folder before performing these actions.

After you finish, you can enable your IDE Settings Sync.

Blaz Krizaj, unfortunately, you're right. That plugin is pretty far from being stable. Here's the issue you mentioned.

1
Comment actions Permalink

I don't see what the point of settings sync is if it doesn't work across Jetbrains IDEs. Most of us use multiple IDEs on one machine I would have thought and syncing things like the keymap is the biggest potential advantage. 

2
Comment actions Permalink

Can't agree more. I ended up using repository settings sync for each IDE but it is super annoying since they aren't synced :/

0
Comment actions Permalink

There's no feature request for that on our tracker: https://youtrack.jetbrains.com/newIssue?project=WI
If I am not missing anything, it should be possible to share data that IDE Settings Sync keeps between different platform products.

0
Comment actions Permalink

I think sync plugin is terrible.

I want to sync live template across different ide,lilke idea and webstorm.

 

and now it not wok.

2
Comment actions Permalink

Same here, tried both methods and none of them is working...

0
Comment actions Permalink

Same here. I want appearance and keymap to sync!

 

0
Comment actions Permalink

Repository settings is not working for me at all, , Rubymine 2019.2.4, even with IDE Settngs Sync Plugin disabled (nothing is ever written to the remote repository).

0
Comment actions Permalink

This was because push to master was disabled on GitLab. I figured this out by going to `/Users/username/Library/Preferences/RubyMine2019.2/settingsRepository/repository` and attempting to push manually, and getting the pre-commit hook failure.

I fixed it by ensuring that pushing to the `master` branch is enabled for the repo. In GitLab Project Settings -> Repository -> Protected Branches -> delete `master`.

There was no error message indicating this, though, it just looked like the sync was successful.

0
Comment actions Permalink

It would be great if this feature could be removed until it is actually implemented properly. At the moment it seems to just serve to waste people's time.

2
Comment actions Permalink

I don't want the feature removed, it works, but it can be hard to get set up correctly.  One of the main problems is that it doesn't report all failures properly, but they've opened a bug for that, so hopefully it will be improved:  https://youtrack.jetbrains.com/issue/IDEA-227546

0

Please sign in to leave a comment.