Impossible to use TODO s in SQL files?

Completed

I've spent 2 hours trying something as "simple" as getting SQL files to have syntax and tool support for TODOs but apparently SQL files have no syntax support for that.

How can it be added? I tried to modify it but it looks like SQL files are not modifiable by definition.

 

Thanks,

6 comments

@Albert Camps

What do you mean under `SQL Files are not modifiable`? Could you provide a screenshot?
Since, I can't reproduce:



0

Hi, it looks like it's not recognising them for me... somehow. Do I need to create a project or something?

0

I created a project and added a directory to the project. Moved the files there and it worked!

 

Thanks for your time and help!

0

I guess it's related to this issue, it used to work fine in 2017.2.3: https://youtrack.jetbrains.com/issue/DBE-6327

 

1

Hi using latest 2018.2.5 does also not show any TODO from comments.

Just for testing I used pattern .*todo.* but did either not work - wether just case sensitive or insensitive.

This is pain

0

Made sure whats happen with new release 2019.1

DataGrip 2019.1
Build #DB-191.6707.12, built on April 3, 2019

Still same issue - no coloring - no items in list

0

Please sign in to leave a comment.