How to disable auto-indent of HTML tags

When I use 'auto-complete close tags', IDE indents the auto-closed tag with a tab, thus ruining my own indentation, that I like to keep myself, it there a way to disable that behavior?


Hi there,

Can you be a bit more specific with the code sample (just screenshot might be fine for now)? I mean -- how it looks before and after completion -- want to see if there anything specific there.

But in general -- it performs code formatting .. so it must be following the settings from "Settings/Preferences | Editor | Code Style | HTML"


Yeap, sure. This is the initial state:

Then I type '/', auto-closing tag action occurs, and it now looks like this:

That nasty auto-indent ruins my own indentation.
I've tried several options in "Settings/Preferences | Editor | Code Style | HTML" before posting, but none of them helped.



I think the only way (if we considering Code Style settings only) is to add p tag to the "Do not indent children of" list. It does the job ... but it affects code formatting in general and not just auto-indenting... so quite likely will be an unwanted way.

Other than that -- try disabling "Settings/Preferences | Editor | General | Smart Keys --> Auto-close tag on typing </ " option and complete closing tags manually (typing the outstanding p> part in full).

Unfortunately I do not know any other option (nothing else comes into my mind right now) that would disable indenting in such completion case (but check other options on Smart Keys settings page just in case). Maybe JB support team can help here.


Please sign in to leave a comment.