CLion Doing "Crazy" Things; Regex Search Fails On Plain Text, Tabs Go To Different Columns On Adjacent Lines


I just noticed this an hour or so ago. I rebooted my machine, reindexed CLion project files. Still 'crazy'.

The first indication was when I tried a global search for a variable, and it got ZERO hits, even though I had started the search by highlighting the symbol I wanted to search for. It was simple camel-case text. After clicking/unclicking search options, scope, retrying, etc. I discovered that if I unchecked "Regex" in the search options it would find the text just fine. There are NO regex characters in the string I was searching for, and in the past Regex searches produces exactly the same results as a non-regex search for simple text like this.

Later, I was aligning comments on a new section of code, and CLion is tabbing to different columns on adjacent lines, for example, on one line I tab from column 46 and it inserts three spaces, taking me to column 49. On the next line, if I tab from column 46 it inserts four spaces, taking me to column 50. If I go up two lines and press tab from column 46, it inserts two spaces, taking me to column 48. I am using the same fixed-spacing font I always have.

I'd worry about a hardware issue, but every other application I'm running works fine; and typically hardware issues cause hard crashes rather than odd behavior like this.

Has anyone else seen strange behavior like this? I'm at a loss as to how to proceed. I am utterly dependent on CLion to do my work. I think while I wait for a response I will look into going back to an earlier version of CLion to see if things improve.

CLion 2018.1.3
Build #CL-181.5087.36, built on May 23, 2018
JRE: 1.8.0_152-release-1136-b39 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.4.0-62-generic


UPDATE: Rolled back to CLion 2018.1.2. Regex search now works properly, but tabs still go to a random column, even on the same line. If I backspace a few characters, then press TAB again, it will go to a different column than before. I can repeat that and sometimes it will go to the same column twice, but frequently goes to a different column.

UPDATE 2: Tab problem only seems to occur on lines where the comment starts with three slashes (as in Doxygen-enabled comments).

 UPDATE 3: Upgraded to 2018.2 EAP. Regex search functions properly. Tab issue remains, as described in Updates above.


Hi, @imbs!

Unfortunately, I can't reproduce the tabulation issue. Could you please record a screencast illustrating the issue or provide a code snippet with which the issue can be reproduced?  


Tabulation issue: It's actually pretty easy to reproduce, and I have now also confirmed the same issue on CLion 2018.1.3 for Mac. Place a line comment at the end of a line of code, but be sure you have three slashes instead of two (indicator to Doxygen that it is a documentation line). Example:

int main(int argc, char *argv[]) {}         /// test comment

Position the cursor anywhere in the white space between the end of any code on the line, and the three-slash comment. Press Delete a few times, until the cursor is over the first of the three slashes. Then press tab to 'align' the comment to the next tab stop. Repeat this a few times, deleting various numbers of spaces, always stopping when the cursor is on the first slash, and press Tab. It will tab to a different column almost every time.

On the Regex search issue, having tried 2018.1.2 and 2018.2 EAP (both worked properly), I reinstalled 2018.1.3 (the version I originally had the problem with), and regex search now works correctly, so there was some sort of transient issue, or I had some specific set of options selected that have changed.

btw, I REALLY like the new tab selector areas on the left, right, and bottom of the screen in 2018.2 EAP. I've been wishing that was available, especially when I'm working on CMake files. If I brought up some other window at the bottom, the CMake window would disappear and the only way to get it back was clicking View->Tool Windows->Cmake, which was a lot of extra steps for a lazy guy like me. Now, easy-peasy! Click the CMake tab at the bottom of the screen and voila!


Thank you for such a detailed description of the tabulation problem! We've created the issue in our tracker: Feel free to comment or upvote, follow it to get updates.


Glad to be of assistance. You do such a great job of support, Anna! I know it can be challenging to figure out some issues, especially if the description isn't clear, so I try to make it as easy as I can for the support team(s). Plus, I want to be sure I'm not just being a nimrod, and that I haven't complained about something that is entirely my fault.


Thank you for your kind words! Don't hesitate to report any issues here, or via email (clion-support at, or in our tracker.


Please sign in to leave a comment.