Cannot find bundler

under mac, i have ruby and bundler installed

$ which ruby
$ ruby --version
ruby 2.5.1p57 (2018-03-29 revision 63029) [x86_64-darwin17]
$ which bundle
$ bundle --version
Bundler version 1.16.2
$ gem list rubygems

*** LOCAL GEMS ***

rubygems-update (2.7.7)

i am familiar with [ruby plugin documentation][1]; i configured ruby sdk

in the view above, i noticed that bundler is not listed (neither rspec, etc.)

and of course i have installed the ruby plugin

i do not know what the structure should look like, but i do see bundler in the external libraries of the project but not the gems i have installed with bundler under the project (i have a Gemfile and .bundle/config file within the project)

yet, i do not see bundler in "Tools | Bundler" as the documentation depicts, or any other ruby related menus (irb console, etc.)

when i edit the run\debug configurations, i get the error message "Run Configuration Error: Cannot find Bundler in ruby 2 SDK.

because of that, i am unable to neither debug, not run the project.

what am i missing?
how can i fix it?
how do i get intellij to show me the "Tools | Bundler" menu?

thank you!



i created a new ruby project from scratch. although most of the configurations\settings above came builtin, and i can even see the gems tab in the project settings and the bundler menu

but i i still unable to run my program under bundler and have the same error on the run\debug configurations.




could you please specify what IDEA and Ruby plugin versions are you using. In addition, would it be possible to attach idea.log (Help | Show log in), you can upload it to any file hosting site or send me to


intellij idea version 2018.1.4

ruby plugin version 2018.1.20180515


pulled the log from ~/Library/Logs/IntelliJIdea2018.1/idea.log, you can find it in


This is an issue with Latest and 2018.2 Beta rubymine. The problem is with Ruby 2.4.x bundler is now a "default gem":

gem list | grep bundler
bundler (default: 1.16.2, 1.6.1)
bundler-audit (0.5.0)
bundler-unload (1.0.2)
rubygems-bundler (1.4.4)


So it's shipped with ruby and installed in a slightly different place. Rubymine needs to update it's probes to look for bundler in a different place.

Regular unix commands reveal that despite internally it is in a different location, externally it still resides in the same place:


which bundler                                                       




I'm in the same situation!

Ruby 2.2.2

IntelliJ IDEA 2018.2.5 (Ultimate Edition)
Build #IU-182.4892.20, built on October 16, 2018
Licensed to Hidehiro Nagaoka
Subscription is active until September 15, 2019
For educational use only.
JRE: 1.8.0_152-release-1248-b19 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.1

As for me, the reason is that the project is detected like JRuby project. So I re-created the project like Ruby on Rails and it worked perfectly!


@Brodock, @Qw3l3qjvj,

could you please check whether the problem with gems persists in RubyMine 2018.3 RC2? 


@Olga I don't see this issue in 2018.3 RC anymore


Please sign in to leave a comment.