Made the python interpreter in Pycharm an Python notebook

Answered

So note sure at all how I did this, but I somehow made the python interpreter that is in PyCharm behave and look like an IPython notebook(see picture)

Only thing I can think of that I had changed recently, is that I was having some issues with different versions of python acting as the default in PyCharm, so I deleted all of the Project interpreters that were in PyCharm, and just added a single one via the system interpreter submenu in the add python interpreter dialog box. Has this happened to anyone else, and if so, how do I fix it as I am not a huge fan of the ipython style.

2 comments

Hello! Please go to  Preferences| Build, Execution, Deployment| Console| Python console  and unselect the option "Use IPython if available". Does it help?

0

Thank you. That was the issue.

0

Please sign in to leave a comment.