Strange font issue when using Material UI

Answered

Hi,

I've just setup a fresh install of PhpStorm on a Windows 10 machine (also a fresh install). I've installed the Material Theme UI plugin, however after I restart Php Storm... the fonts look completely broken..

I've tried going into preferences and changing font, but it doesn't seem to make a difference. It doesn't seem to be all fonts - as you can see, the Material Theme UI popup seems ok, it's just all the interface! ... makes it a bit tricky to use.

Just wondering if anyone has faced a similar issue at all?

Thanks in advance!

14 comments
Comment actions Permalink

Hi there,

It's a problem with a font of some kind. You may see it even on fresh install with no GUI theme plugins. Try manually selecting another font .. or if you know which one it is -- try reinstalling the font.

I personally do not know the better cure.

0
Comment actions Permalink

Does it work fine without Material UI plugin activated?

0
Comment actions Permalink

It works fine without the plugin - very odd!

0
Comment actions Permalink

Will it work if you choose another font at "Settings | Appearance & Behavior | Appearance --> Override default fonts by" ?

3
Comment actions Permalink

Hello Dan,

I have same problem as you described. Windows 10 + Phpstorm - when activating material theme the font looks like on your screenshot - very odd.

Any help appreciated.

0
Comment actions Permalink

Did you try a suggestion posted above?

0
Comment actions Permalink

Hi Dmitry,

Override default fonts by .... - checked - resolved my issue!

Thanks for help.

2
Comment actions Permalink

Cool, thanks for letting us know

0
Comment actions Permalink

Had something like this for Webstorm, what I ended up doing was:

1. Downloading Roboto font:
https://fonts.google.com/specimen/Roboto?selection.family=Roboto

2. Installing the fonts
3. Restarting WebStorm

That fixed my issue.

4
Comment actions Permalink

@Fadi Nice!!! Thanks your

0
Comment actions Permalink

I'm having this issue but can't even navigate around the UI to make any of the above changes, since I can't read any of the menus, etc...  How do I proceed?

0
Comment actions Permalink

@Rsimpson

Not sure if it will fix your issue but doesn't hurt to try it. Try my three steps above.

This step might not be needed but it's something that I have run into before. Delete Roboto fonts from the system before installing/reinstalling them.

0
Comment actions Permalink

@Fadi, I did dl and install those fonts... restarted WebStorm, still saw the whacked fonts but was able to fuss my way into uninstalling the material theme.  Upon restarting WebStorm, I re-installed the theme and now everything looks good.  Thanks for the help.

 

x (x)
 
0
Comment actions Permalink

hi dan

i had this problem as well and i managed to fix it, this happened because you changed your system font, to fix this you have to change your system font back to default.

make a new notepad file on your desktop and name it "change default font.reg" do not add the quotation marks

then copy and paste this into this notepad file.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts]
"Segoe UI (TrueType)"="segoeui.ttf"
"Segoe UI Black (TrueType)"="seguibl.ttf"
"Segoe UI Black Italic (TrueType)"="seguibli.ttf"
"Segoe UI Bold (TrueType)"="segoeuib.ttf"
"Segoe UI Bold Italic (TrueType)"="segoeuiz.ttf"
"Segoe UI Emoji (TrueType)"="seguiemj.ttf"
"Segoe UI Historic (TrueType)"="seguihis.ttf"
"Segoe UI Italic (TrueType)"="segoeuii.ttf"
"Segoe UI Light (TrueType)"="segoeuil.ttf"
"Segoe UI Light Italic (TrueType)"="seguili.ttf"
"Segoe UI Semibold (TrueType)"="seguisb.ttf"
"Segoe UI Semibold Italic (TrueType)"="seguisbi.ttf"
"Segoe UI Semilight (TrueType)"="segoeuisl.ttf"
"Segoe UI Semilight Italic (TrueType)"="seguisli.ttf"
"Segoe UI Symbol (TrueType)"="seguisym.ttf"
"Segoe MDL2 Assets (TrueType)"="segmdl2.ttf"
"Segoe Print (TrueType)"="segoepr.ttf"
"Segoe Print Bold (TrueType)"="segoeprb.ttf"
"Segoe Script (TrueType)"="segoesc.ttf"
"Segoe Script Bold (TrueType)"="segoescb.ttf"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes]

"Segoe UI"=-

 

after this save the file then close it then run it.

this will change your system font to the default font and also fix your pycharm problem

2

Please sign in to leave a comment.