Namespace autocompletion does not show interfaces

Hello,

 

It's in the title. The namespace autocompletion shows classes (like implementations of the interface), but not interfaces themselves. So I have to type out the whole path. I can only assume this is a bug.

 

Thanks, Michael

13 comments
Comment actions Permalink

We have 4+ people experiencing this issue, at least since the upgrade to 2018.3 but it might have been happening in the previous update too. The namespace auto-completion does not load aside from classes already in use within the current file.

We all get PHPStorm via Snap on Fedora 29. We have all been auto-upgrading via the Snap update process, rather than doing a clean install, e.g. my PHPStorm setting folders in my home directory go back to PhpStorm2016.3.

PHPStorm about info:

PhpStorm 2018.3
Build #PS-183.4284.150, built on November 21, 2018
Licensed to <our company>
JRE: 1.8.0_152-release-1343-b15 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.18.17-300.fc29.x86_64

1
Comment actions Permalink

No other reports so far. Try to backup & remove your config dir (C:\Users\<username>\.PhpStorm2018.2\config on Windows). Check if the issue happens in a brand new project after that.

If you're on Linux - please try to delete existing IDE installation & unpack it anew.

 

0
Comment actions Permalink

I recently upgraded to 2018.2 and am now seeing this. 

I have this PHPStorm about info:

PhpStorm 2018.2.4
Build #PS-182.4505.42, built on September 27, 2018
Licensed to <the place I work>

JRE: 1.8.0_152-release-1248-b8 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.13.3

0
Comment actions Permalink

Apparently this will be fixed in 2018.3.

0
Comment actions Permalink

The fix is also available with 2018.2.5: https://youtrack.jetbrains.com/issue/WI-43385

(If that's it, of course)

0
Comment actions Permalink

I just referenced an interface in my code and autocompletion seems to work now as expected in 2018.2.5.

0
Comment actions Permalink

The error still persist in 2018.3

0
Comment actions Permalink

You might be experiencing something other. Please illustrate your issue in details.

 

0
Comment actions Permalink

@Dean that's probably https://youtrack.jetbrains.com/issue/WI-44416. 

Try disabling php.fqcn.completion option in Registry (Help > Find Action > Registry...).

0
Comment actions Permalink

Thanks @Dmitry, that fixes the issue for me: PHPStorm is again able to find classes other than those currently in use within the current file.

0
Comment actions Permalink

error persists in 2018.3.1

 

EDIT: Thank you @Dmitry, it's working as a workaround

0
Comment actions Permalink

I have 2018.3 and same issue - no interfaces shown for auto-completion. 

0

Please sign in to leave a comment.