Need help with changing Python interpreter.

Hi,

I'm new to PyCharm and I'm using the latest version.

I installed Python 3.6 globally and navigated to the project interpreter page.

I selected Python 3.6 and after clicking on Apply I was presented with a page asking me to install packages.

Some are shown alongside the latest version.

What happens if I click Apply?

Will the global packages be updated?

Also at the bottom of the page I get:

python packaging tools not found. Install packaging tools.

I don't understand what the above line means.

I thought that just selecting the interpreter would be enough.

Thanks in advance for any help.

Ubuntu 16.04.

PyCharm 2018.1.4

1 comment

 

Hi there,

> What happens if I click Apply?

That won't update packages, it'll save the added interpreter and close the settings dialog.

python packaging tools not found. Install packaging tools.

That means that pip will be installed.

 

0

Please sign in to leave a comment.