Build failure due to maven-annotations-test error

Answered

I have a question that is unseen on the internet - I could find a solution.

I wanted to build my maven project in IntelliJ Idea 17.2.2. Everything went well - I got only one error.
Namely Error:maven-annotations-test:test-fw: java.lang.IllegalStateException: Duplicate key org.jetbrains.jps.model.module.impl.JpsModuleImpl@56a6d5a6 

What can this mean? Is this something with the maven plugin? What is the solution?

Thank you for your time!

B.

12 comments
Comment actions Permalink

Hi.

 

Does it build fine using the mvn tool?

Could you please provide a project example?

0
Comment actions Permalink

Yes, it works fine with maven tool. Just the IDE build does not work. 

0
Comment actions Permalink

please provide a project example.

0
Comment actions Permalink

What do you mean by a project example?

Will a pom.xml make sense?

Thanks!

0
Comment actions Permalink

Hello. pom.xml is not enough.  Any project where the problem reproduces would help.

0
Comment actions Permalink

Well, of course I cannot disclose any of the work I have, but would need the help.

The matter is that I cloned my work into a newly installed IDE and then the problem occurred.

Some additional info is that I cloned the repo by mistake twice - after that having deleted the first clone then cloned second time the same. This way - I don't know how but the IDE showed the same projects twice. But having deleted from the file system the first, I cannot deal really with this. May this be the cause?

Thank you!

0
Comment actions Permalink

Try removing .idea folder and reimporting project from maven model.

0
Comment actions Permalink

Thank you for the comment. I tried, reimported everything, but it didn't work.

I don't know what is the single point of erring in that particular project - which also hinder other projects from being built. This might be a newly aroused bug.

I have rolled backed to IDEA 17.1.6 and everything worked fine. Please be aware of this!!

0
Comment actions Permalink

We were facing exactly the same problem - however it was reproducible only on a single machine / Idea installation. Disabling Maven plugin fixed it. We are not using Maven at all - we are using Gradle (and its Idea plugin to generate the project). Unfortunately, neither I can provide source code. :(

The problem started appearing after upgrade to 2018.2, everything was fine before.

0
Comment actions Permalink

@Jan Klos could you please provide idea.log and build.log, if possible?

0
Comment actions Permalink

Got the same Issue today, I deactivated "Maven Integration" and "Maven Integration Extension" Plugin.

https://www.file-upload.net/download-13362756/idea.log.html

0
Comment actions Permalink

The same here, had to disable both maven plugins in order to build the project

0

Please sign in to leave a comment.