PyCharm does not give me the option to ignore errors for one script

Answered

Up until now, I've been able to right click on any errors in PyCharm and select "Ignore" from the drop down menu. However, I recently took over modifying a script that someone else wrote, and for some reason, while editing it, the option is not there. In other scripts, I can still ignore just fine.

This is the case for all types of errors.

Anyone know what could be causing this?

5 comments
Comment actions Permalink

Hi, could you please take a screenshot of the error you can't ignore and the project tree where the file is placed? Please feel free to send those details to pycharm-support@jetbrains.com

0
Comment actions Permalink

Here is the drop down menu. As you can see, the "ignore" option is not present. This option exists for the exact same code in the other scripts in this directory. The project is much too large to fit in a screen shot, I can get you specific details if you know what I should be looking for

0
Comment actions Permalink

Thank you, which PyCharm version is this? Will it suppress the error if you manually add <module>.ZioCLIAssistant to Settings | Editor | Inspections | Python | Unresolved Reference | Ignore references table?

0
Comment actions Permalink

Current version is 2018.2.1, build number PC-182.3911.33

 

Yes, it will. I have no trouble ignoring the error manually. My only problem is the ignore option being absent from the quick drop down menu when I right click on errors.

0
Comment actions Permalink

Thank you, is this a project file? I mean it's not a scratch and not a file outside of the project root?

0

Please sign in to leave a comment.