New Interpreter Problem: Pip3.7.exe Doesn't Accept --python param

I'm trying to create a new interpreter in Pycharm but when I hit the create button Pycharm is running pip with a --python param that pip doesn't like. Any advice?

4 comments

Hello!

Thank you for contacting PyCharm support.

Could you please provide a screenshot of the 'Add Python Interpreter' window where you create a project interpreter?

Looking forward to your reply.

Regards,

Sergey

https://www.jetbrains.com

The Drive to Develop

0

Hi Sergey - here's the dialog you requested:



0

Hi,

Thank you for the update.

Please clarify which one of these options doesn't work for you?
Also, please clarify what is you PyCharm version?

Looking forward to your reply.

Kind regards,

Sergey

https://www.jetbrains.com

The Drive to Develop

0

Sorry, I haven't noticed it at first. 

On the last screenshot you have chosen the wrong .exe file for "Pipenv executable".

When you choose "Pipenv Environment" the "Pipenv executable" should be detected automatically by PyCharm. If it is not detected, then it means that it is not installed on your machine or PyCharm couldn't find it for some reason.

Please choose the correct "Pipenv executable" path. It should lead to pipenv.exe.

Please also clarify why "Virtualenv Environment" is not suitable for you?

Kind regards,

Sergey

https://www.jetbrains.com

The Drive to Develop

0

Please sign in to leave a comment.