Can't get the settings repository to work in web storm

I use a settings repository for IntelliJ, PyCharm, and Android Studio, but I am having problems with WebStorm. 

After entering the bitbucket repository, it tries to retrieve the settings but never asks for my pass phrase so the authorization fails.

The settings repositories in the other IDEs have been setup for quite some time, but this is a fresh install of WebStorm 2018.2.3

Also, im running linux mint 18.3

If this is not a bug, would someone mind giving me some assistance? 



Are you using app-password to access your repository? For Bitbucket using App Password ( (Required permissions: Repository read/write)) is recommended


thanks for your reply

No, I'm not using an app password for any of the IDEs using a settings repository.

However I tried it with Webstorm and still the same problem: it never asks for any authorization information 


Looks similar to

For me, it asks for credentials on setting up the repository in File | Settings repository

Please try deleting <WebStorm config dir>/settingsRepository/.git_auth file - does it help?




It could be related to that issue, but in my case I'm experiencing the opposite behavior: the dialog does NOT popup

And regarding the suggestion to delete `git_auth`, I had to do that when i first tried to setup a settings repository in intellij when I mistyped my pass phrase, however this time is different because it never asked for the credentials in the first place

to clarify, that file does not exist under my webstorm config dir



Please recreate your issue and provide your idea.log ( - don't paste it here, upload it to some file server and provide a link


When I generated a new ED25519 SSH key pair to use it with gitlab account, PhpStorm display auth fail error for repository created on gitlab (but in terminal I can without errors clone that repository authenticated with ed25519 key). After I generate ssh rsa key, the problem was gone.


P.S. The problem is still exists with PhpStorm 2019.2 (on Ubuntu 18.04)


This problem exists in every single product. They "simplified" their git and github settings but now settings repository can't load the correct ssh keys and http auth doesn't work with MFA / access tokens either.


Basically you have to clone your repo locally and point it at the file system and hope you remember to push every once in a while.


I have this same problem of the credentials NOT being asked for when I try to connect my Git repository with a ED25519 SSH key pair.


Is there really no real solution yet, other then the local repo?


it's always wonderful when you stumble across your own unresolved post for the same problem 2 years later...


This wasn't the exact problem i encountered the last time around, but in case someone is getting an "Auth fail" message, be sure to check whether you're using the ssh or https version of the repo location. jetbrains IDEs require you to use the https version


Please sign in to leave a comment.