Webstorm - Cordova integration

Hi there,

I want to start my first ionic project, however I get error on Corvoda path. this is my setup :-

Downloaded nodejs from their website in a tar file. > I have done the following commands:

npm install phonegap

npm install cordova

npm install ionic 

Then I downloaded webstorm 

create new project > corvoda project 

once the project starts I get the following error :-

"" Create Cordova Project: Error creating Cordova App. Incorrect path "" 

so I read some articles, then I opened Settings> Languages & Frameworks > JavaScript > Corvoda . and modified the excitable path to be as below :-

"" /home/alme7airbi/node-v8.12.0-linux-x64/lib/node_modules/cordova/bin/cordova.cmd ""

 

screenshot



15 comments
Comment actions Permalink

`cordova.cmd` is definitely not a valid cordova executable on linux:)

Please try running which cordova in your system terminal - what is the result?

0
Comment actions Permalink

Hi I used cordova in this location and it works but also when I give webstorm this file it give me the same error

0
Comment actions Permalink

As you can see in this image

0
Comment actions Permalink

please provide your idea.log (https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files) - do not paste it here, upload it to some file server and give me a link

0
Comment actions Permalink

no clues unfortunately... Please can you try enabling debug logging for #com.github.masahirosuzuka.PhoneGapIntelliJPlugin.commandLine.PhoneGapCommandLine category (via Help/Debug Log Settings), recreate the issue (try creating a project) and provide the new idea.log?

0
Comment actions Permalink

what level I should type in there and what is the correct spelling , Thanks 

0
Comment actions Permalink

Just paste #com.github.masahirosuzuka.PhoneGapIntelliJPlugin.commandLine.PhoneGapCommandLine there and press OK

0
Comment actions Permalink

it looks like node can be found on your $PATH. Please try running WebStorm from terminal - does the issue persist?

0
Comment actions Permalink

It works from the terminal, great ! .. 

I still didn't get it, why it works their and from desktop doesn't ? 

0
Comment actions Permalink

is there a way I can fix it ? Thanks 

0
Comment actions Permalink

When being launched from desktop/System menu, WebStorm only sees environment variables configured in ~/.profile (login shell), but not in interactive shell configuration files (like ~/.bashhrc). Possible workarounds:

  • Workaround 1: make required variables available in a login shell (i.e. for bash, move them from .bashrc to .bash_profile).
  • Workaround 2: run IDE from a terminal, via bin/webstorm.sh
  • Workaround 3: edit the desktop launcher and set command to /bin/bash -l -i -c "/path/to/webstorm.sh"

see also https://youtrack.jetbrains.com/issue/IDEABKL-7589

1
Comment actions Permalink

Thank you very much for the help today ! Good luck 

1

Please sign in to leave a comment.