Javascript Validations

I have my projects set to JS5.1 as we have to continue to support IE11, though  mainly focused on current browser.


IE11 does support 'const' and 'let', but these are currently marked invalid as they are not supported in the target language version, is there a way I can customise this so it can treat 'const' / 'let' as valid?

TIA
Rob

4 comments

Try changing JavaScript Language version to JavaScript 1.8.5 - it supports both `const` and `let`

 

0

Hi again,
Though the above did solve my problem with validating let and const it I noticed that they don't syntax colored as other language keywords.

Is there a way to fix that...

 

TIA

Rob

0

No, there is no way to fix this on your end...

Please follow https://youtrack.jetbrains.com/issue/WEB-32124 for updates

0

Please sign in to leave a comment.