Can not parse PHPUnit version (v.5.7.x) using composer autoloader on newest phpStorm

I know that there were a bug with in phpStorm 2017.1 version. However I'm using the latest stable version of phpStorm. I installed PHPUnit via composer and I don't use docker or VM.

I attache the two screenshots with error message and my project tree structure regards PHPUnit files.


When I use phar version I have no problem with running tests.

2 comments
Comment actions Permalink

I can't edit my post, so I need add extra comment here.

The variable from composer's include_path is $vendorDir . '/phpunit/phpunit

0
Comment actions Permalink

Your vendor/phpunit/phpunit directory looks weird, different to what I've got with composer require phpunit/phpunit:5.7.27.

The PHPUnit executable is not supposed to have the .php extension.

Could you please share your composer.json?

0

Please sign in to leave a comment.