Deploying/running app on device takes long time in latest version.

Answered

Just started on an upgrade project for our app, haven't been into AppCode since July. Upgraded to latest version, 2018.2

I notice that it takes way longer to deploy for running than I'm used to. It always used to be a bit slower than Xcode, but now it's much slower.

When I click on run, this happens:

1. /private/var/containers/Bundle/Application/... is displayed in the console

2. The loading screen for my application is displayed on the phone

3. about one minute or more later, the app actually starts. in Xcode, this takes seconds.

 

This makes it untenable to do work using AppCode. Any ideas on why it is so slow? I haven't changed anything in my project settings, just upgraded AppCode as I mentioned.

 

Pointers appreciated.

4 comments

Mathias,

It would be helpful if you:

1) try out latest 2018.3 EAP and see if the problem is reproducible there

2) in case it does, please add the following line into Help | Debug Log Settings:
#com.jetbrains.cidr.execution.deviceSupport
after reproducing the issue collect idea.log(s) from Help | Show Log in Finder, create an issue in our tracker and attach the log to it.

0

If you look at my other thread regarding 12.0.1 - when I am now running my app on 12.0.1, and after fixing the stuff in that thread, it no longer takes forever. On 12.0 it does.

0

Mathias,

Could you specify your iPhone model? Is that XS / XS Max?

0

Please sign in to leave a comment.