WebStorm some browsers (Safari & Firefox) are not working

Hi,

I'm pretty new to WebStorm and have just set up a basic project with HTML, CSS/Scss. During the last few days, I've just tested the project on Google Chrome and it was working perfectly fine. However, when I try to open it in Safari or Firefox from the IDE, it's not working. Opera, on the other hand, is again working. 

I'm getting server not found errors on both browsers. I'm currently working on macOS 10.14. I'm running WebStorm 2018.2.4.

I really appreciate any help. Thanks in advance.

 

 

12 comments
Comment actions Permalink

>when I try to open it in Safari or Firefox from the IDE, it's not working. 

how do you open it? BTW, does it work if you open it in these browsers when not using the IDE (by starting the browser and enterig app URL)?

>I'm getting server not found errors on both browsers

please attach a screenshot of the error

0
Comment actions Permalink

I open it by using the browser popup in the editor. 

When I open the HTML file from the file system it works perfectly fine. So only opening it from WebStorm directly doesn't work. 

I've attached a screenshot from Firefox. Let me know if you need more information. 

0
Comment actions Permalink

strange... Does exactly same address work in Chrome? Also, please try enabling Allow unsigned frequests in Settings | Build, Execution, Deployment | Debugger - does it make any difference?

0
Comment actions Permalink

Yes, in Chrome it works perfectly fine. I also copied over the address from Firefox. 

No, I've tried that before and now again. It does not make any difference. 

0
Comment actions Permalink

can you check if clearing caches, etc (see https://discussions.apple.com/thread/5958496) helps?

0
Comment actions Permalink

No, this doesn't help me either. Can I somehow reset all settings in WebStorm? I deleted it and reinstalled it, however, it seems to keep the settings. Is it enough and reasonable to delete the WebStorm folder in application support directory?

0
Comment actions Permalink

I don't think that resetting configuration helps... Anyway, please try the following:

rm -rf “$HOME/Library/Preferences/WebStorm2018.2″
rm -rf “$HOME/Library/Caches/WebStorm2018.2″
rm -rf “$HOME/Library/Application Support/WebStorm2018.2″
rm -rf “$HOME/Library/Logs/WebStorm2018.2″
0
Comment actions Permalink

BTW, what is logged in Firefox/safari console once the issue occurs?

0
Comment actions Permalink

No, resetting the configuration didn't help. The normal console doesn't give me any output for both browsers.

0
Comment actions Permalink

I have found something. With 127.0.0.1 it works fine. So somehow it can't resolve localhost. Any ideas how I could fix this? 

0
Comment actions Permalink

Thank you very much! Finally, I could solve it! The /etc/hosts file was somehow empty. Just added the default content again and now everything works as expected! Have a nice day!

1

Please sign in to leave a comment.