CLion fails to properly terminate gdb (or program) -- using WSL


Using CLion 2018.2.4 on Windows 10 x64.

Am not sure if this is related to WSL specifically. It doesn't happen with most programs, but I have an application that embeds the FreeRTOS Windows port. I can run and debug this app just fine, but when debugging, if I hit the stop button (Ctrl+F2) to end the session, it shows the pause button for 5-10 seconds more and then says "Process finished with exit code 0" in the status bar. However, the gdb and app processes are still shown in Windows task manager and I have to kill them manually to avoid them accumulating.

Note that if I run this app rather than debug, I can stop it fine, and if I run the app from the command line and hit Ctrl+C it terminates correctly, so am not sure what is the issue with termination via gdb in debug mode.

Any help appreciated!

1 comment

Hello! Please enable debugger logging as described here, reproduce the issue and send the resulting idea.log file to clion-support at Thanks. Do not forget to disable debug logging after that. Note that logs might contain private user's information (like file paths and names). 


Please sign in to leave a comment.