IntelliJ IDEA 64-bit won't start but 32-bit starts on Windows 10 64-bit operating system

Answered

IntelliJ IDEA 64-bit version won't start at all when i click on it, but 32-bit version works fine except when i try to build Android program, the program stuck on indexing.

It's one of the following which i guess causes the problem:

  • after i downloaded the trial version of WebStorm, or
  • after i download Oracle VirtualBox, and turn off hyper-v

Any idea what causes the problem?

 

Solutions:

  • I turned on hyper-v and nothing changed.
  • Re-installed the program and downloaded it again.
  • make sure JRE and JDK are downloaded and set in environment variables.

None worked for me.

18 comments
Comment actions Permalink

Try to run it via .bat file from the command line and examine the output.

1
Comment actions Permalink

Output:

  • Error occurred during initialization of VM
  • agent library failed to init: instrument
0
Comment actions Permalink

So the issue is incorrect JVM options that IDE picks up. Please locate and delete custom .vmoptions file.

0
Comment actions Permalink

Hello,

I have the same problem with the release 2019.1.1.

X64 version won't start, x86 version works fine.

If I'm starting from the idea.bat I got this messages, but it starts:

C:\Program Files\JetBrains\IntelliJ IDEA 2019.1.1\bin>idea.bat
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by com.intellij.ide.ClassUtilCore to field sun.net.www.protocol.jar.JarFileFactory.fileCache
WARNING: Please consider reporting this to the maintainers of com.intellij.ide.ClassUtilCore
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release

I've tried to edit the idea64.exe.vmoptions like this but still the idea64.exe won't start:

-Xms128m
-Xmx750m
-XX:MaxPermSize=256m
-XX:ReservedCodeCacheSize=240m
-XX:+UseConcMarkSweepGC
-XX:SoftRefLRUPolicyMSPerMB=50
-ea
-Dsun.io.useCanonCaches=false
-Djava.net.preferIPv4Stack=true
-XX:+HeapDumpOnOutOfMemoryError
-XX:-OmitStackTraceInFastThrow
-XX:MaxJavaStackTraceDepth=-1

Any ideas ?

-----------------------

So, I've deleted the old settings files imported from a previous version of IntelliJ. It seams that a plugin failed to run on x64.

Thank you

0
Comment actions Permalink

These warnings are harmless and do not show the real cause of the problem. Check the logs: https://intellij-support.jetbrains.com/hc/articles/207241085.

0
Comment actions Permalink

Just downloaded 2020.1.1 (ideaIC-2020.1.1.tar.gz 640.8 MB)

Could not get IDE to start:

./idea.sh
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Error occurred during initialization of VM
Multiple garbage collectors selected

Could NOT find any logs at this point...

In the bin directory - Edited idea64.vmoptions

Deleted line with:

-XX:+UseConcMarkSweepGC

Saved file

Now IDE starts fine

Running CentOS 7

java -version
openjdk version "11.0.7" 2020-04-14 LTS
OpenJDK Runtime Environment 18.9 (build 11.0.7+10-LTS)
OpenJDK 64-Bit Server VM 18.9 (build 11.0.7+10-LTS, mixed mode, sharing)

 

 

0
Comment actions Permalink

Update to above edits

After I exited the IDE and restarted - the error came back

Had to edit the file:

~/.config/JetBrains/IdeaIC2020.1/idea64.vmoptions

Deleted line with

-XX:+UseConcMarkSweepGC

Now everything is good

0
Comment actions Permalink

Thanks for the info. However, original problem in this thread was reported for Windows and is not related to your issue. In your case the problem was caused by invalid VM options in idea64.vmoptions, something about the garbage collectors specified. It's likely that this file was customized incorrectly. It would be useful if you could post the full contents of this file before the fix.

0
Comment actions Permalink

Contents of idea64.vmoptions BEFORE deletion of line with -XX:+UseConcMarkSweepGC

 

-Xms128m
-Xmx750m
-XX:ReservedCodeCacheSize=240m
-XX:+UseConcMarkSweepGC
-XX:SoftRefLRUPolicyMSPerMB=50
-ea
-XX:CICompilerCount=2
-Dsun.io.useCanonPrefixCache=false
-Djdk.http.auth.tunneling.disabledSchemes=""
-XX:+HeapDumpOnOutOfMemoryError
-XX:-OmitStackTraceInFastThrow
-Djdk.attach.allowAttachSelf=true
-Dkotlinx.coroutines.debug=off
-Djdk.module.illegalAccess.silent=true
-Dawt.useSystemAAFontSettings=lcd
-Dsun.java2d.renderer=sun.java2d.marlin.MarlinRenderingEngine
-Dsun.tools.attach.tmp.only=true

0
Comment actions Permalink

This set of options should work fine as it defines only one GC.

It could be that you have JAVA_TOOL_OPTIONS and/or _JAVA_OPTIONS system environment variables set overriding the GC which is causing the issue.

0
Comment actions Permalink

As best as I can tell neither of these env vars are set

echo $JAVA_TOOL_OPTIONS && echo $_JAVA_OPTIONS

show as blank

0
Comment actions Permalink

Could you please share IDE logs using Help | Collect Logs and Diagnostic Data? Upload the file at https://uploads.services.jetbrains.com/.

0
Comment actions Permalink
Uploading...
File uploaded: idea-logs-20200522-135131.zip
Upload complete!
0
Comment actions Permalink

The logs show you have `-XX:+UseG1GC` VM option defined somewhere which is causing the issue with the default set of VM options.

Double check there is no such option in `/home/john/.config/JetBrains/IdeaIC2020.1/idea64.vmoptions` and in `IDE_HOME/bin/idea64.vmoptions`.

0
Comment actions Permalink

Looks like it is the very last setting:

-Xms128m
-Xmx961m
-XX:ReservedCodeCacheSize=240m
-XX:SoftRefLRUPolicyMSPerMB=50
-ea
-XX:CICompilerCount=2
-Dsun.io.useCanonPrefixCache=false
-Djava.net.preferIPv4Stack=true
-Djdk.http.auth.tunneling.disabledSchemes=""
-XX:+HeapDumpOnOutOfMemoryError
-XX:-OmitStackTraceInFastThrow
-Djdk.attach.allowAttachSelf
-Dawt.useSystemAAFontSettings=lcd
-Dsun.java2d.renderer=sun.java2d.marlin.MarlinRenderingEngine
-Dsun.tools.attach.tmp.only=true
-XX:+UseG1GC

0
Comment actions Permalink

That explains the issue. You've modified the default VM Options by adding a second GC which has caused the issue. You can use only one GC option.

0
Comment actions Permalink

-XX:+UseG1GC was set in:

`/home/john/.config/JetBrains/IdeaIC2020.1/idea64.vmoptions`

But NOT:

`IDE_HOME/bin/idea64.vmoptions`.

0
Comment actions Permalink

Thanks for the help and identifying the problem.

Normally I do not mess with these files, so not sure how that option worked its way in there.

Anyway - thanks again.

0

Please sign in to leave a comment.