Some conflicts were found in the installation area

I'm routinely getting the same warning in every incremental update:

Some conflicts were found in the installation area

File: plugins/DatabaseTools/lib/database-impl.jar
Action: Update
Problem: Modified
Solution: IGNORE

Is it something to worry about?

If I hit "Proceed" the update completes without (apparent) issues but it's the third update in a row where it happens.

22 comments
Comment actions Permalink

Could you please attach a screenshot of this?

0
Comment actions Permalink

I'm sorry, Dmitry. I just proceeded with the update to 2018.2.5 after writing down the details.

But the dialogue is identical to e.g. https://stackoverflow.com/questions/28587234/android-studio-update-some-conflicts-found-in-installation-area save for the additional button and the file reported (mine is "plugins/DatabaseTools/lib/database-impl.jar").

0
Comment actions Permalink

It seems that you have a modified version of this JAR. Please remove your installation and install it back, it should stop the issue from appearing on the next update: https://youtrack.jetbrains.com/issue/IDEA-163331

0
Comment actions Permalink

Done!

(BTW, I didn't modify any file inside %programFiles%\JetBrains\PhpStorm 2018.2, not at least intentionally.)

0
Comment actions Permalink

I had this same problem in Webstorm for MacOS, for two updates in a row I was getting  "Some conflicts were found in the installation area" with a long list of files of unknown purpose.  The fix: following the instructions above, I just went back to the webstorm download site, downloaded a new version, renamed it "old", installed the new, verified that everything was working as before, including updates, and then deleted the "old" version.  I assume it is a flaw in the updater, since I don't know where these conflicts came from.  Probably a similar fix will work on Windows.

0
Comment actions Permalink

I have the similar problem for around the year now.. updated to several versions, and this very screen keeps showing persistently.

1
Comment actions Permalink

Is it an IntelliJ IDEA installation? Do you have really miss bin/idea.exe in your installation?

0
Comment actions Permalink

This is like the third time that happened this year.
No, I didn't modify anything. Yes, I am sure.
No, the update is obviously not being applied.
No, I can't choose "REPLACE" for 90%+
Patch from 2020.2.idk to 2020.3 didn't show any problems btw.
(I am on Archlinux btw, just using a MacOS theme)

1
Comment actions Permalink

Do you have a JetBrains Toolbox utility installed? If not, I would highly recommend to use it as it is cool & convenient way to install, update and launch your JetBrains IDE applications. Here is the link:

https://www.jetbrains.com/toolbox-app/

0
Comment actions Permalink

I am getting this for *every* beta update on a Mac M1. Extremely frustrating.  

0
Comment actions Permalink

That's weird. Did you try to remove IDE installation & install it anew? 

0
Comment actions Permalink

I've had this problem with every Intellij update for years, across multiple Macs:

The instructions say "please download this version from the developer website and reinstall it from scratch", but it's not really clear which version they're suggesting to download or exactly how to install from scratch (uninstall first, or just install the new version?).  Considering this happens on nearly every upgrade, the manual recovery could be clearer.

0
Comment actions Permalink

In general, the suggestion is to uninstall the previous version and then install a newer version.
By the way, I never personally had this problem with the JetBrains Toolbox-based installations and I would like to recommend this app to everyone, this is a really convenient way to install, update & launch JetBrains IDE's.

Just in case:
https://www.jetbrains.com/toolbox-app/

0
Comment actions Permalink

Thank you, Vasiliy Yur, that did work for me.  I'll use the toolbox app for upgrades from now on.

0
Comment actions Permalink

Running Toolbox is not a solution for me. For starters it installs Android Studio in some remote Application Support versioned folder. I am not even sure what mess it might make if I change it to install to /Applications. Then the window of the Toolbox is not even showing up anywhere in application switcher or dock so it's hard to get back to its window.

Toolbox didn't detect my existing Android Studio install at all (which is in Applications as is with all the Mac apps), even tho it did detect PhpStorm.

The issue with the upgrade seems to be related to M1 machines. The file that it couldn't find was "Contents/jre/Contents/Home/Frameworks/JavaNativeFoundation.framework/Versions/A/._JavaNativeFoundation.tbd". This folder did contain a JavaNativeFoundation.tbd, so I copied it to ._JavaNativeFoundation.tbd, but then the upgrade complained that it was modified. The entire JavaNativeFoundation.framework seems to be related to M1 macs, it doesn't exist at all on Intel based macs.

So the upgrade is broken on M1 macs. Please fix this. I had to trash old .app bundle and replace manually from the Android webpage. Of course the new version didn't contain a "._JavaNativeFoundation.tbd" file either. I don't want to do this for every minor version (2020.3.1.23 to 2020.3.1.24 this time).

P.S.: PhpStorm updated from 2021.2 to 2021.2.1 just fine, it is M1 build as well.

0
Comment actions Permalink

No similar reports about _JavaNativeFoundation on M1 or these issues on M1 in general. If that was true, we'd receive hundreds of similar complaints.

The problem seems to be limited to your installation. Also, I'm not sure about this step: "I had to trash old .app bundle and replace manually from the Android webpage". Why didn't you download IDE from the official source?

0
Comment actions Permalink

The issue is with Android Studio, not PhpStorm. I downloaded Android Studio from the official source. I installed it on a brand new iMac M1 that I just got this week, installed Android Studio 2020.3.1.23, used it few days, then it showed there was an update 2020.3.1.24, which failed. Never had any problems on Intel based macs, in fact it updated fine on the old Intel mac I used till now.

I was just mentioning that Android Studio didn't update, when PhpStorm updated just fine.

0
Comment actions Permalink

I see, thanks for the clarification. I was a bit confused since this is a PhpStorm community thread. You can forward issues with Android Studio to https://issuetracker.google.com/issues?q=componentid:192708&s=modified_time:descfirst&pli=1

0
Comment actions Permalink

Thanks! I have filed b/198782629 there: https://issuetracker.google.com/issues/198782629

Got confused by the exact string match in the error title.

0

Please sign in to leave a comment.