Spell checking doesn't work in Markdown files

The spell checker works fine, but there's no option to enable spelling inspection highlighting in the UI. All you get is a checkbox at the top of the scrollbar telling you you have "X typos" in your document, with no clue where they are! I'd think spell checking for Markdown is more important than any other file type, since it's the one most often used by git repos for content authoring.

What are the chances we can get this fixed in the next release?

4 comments
Comment actions Permalink

Works fine for me:

 

what severity is chosen in Settings | Editor | Inspections | Spelling | Typo? try setting a different severity level - does it work? Also, what mode do you use for .md files viewing - Editor only, Editor + Preview, Preview only?

0
Comment actions Permalink

Does not work for me either, tried both PyCharm and IntelliJ :(

0
Comment actions Permalink

Can't reproduce

Is the Proofreading | Typo inspection enabled, what do its settings look like?

0
Comment actions Permalink

I've managed to reproduce this, and it's due to "Reader Mode" being on. Go to Settings | Editor | Reader Mode and ensure that Error and warning highlighting, inspection widget is ticked to show inspection errors.

0

Please sign in to leave a comment.