Find in Path behaves strange. It looks always for the same code. Is it a bug?

Answered

Hi Team,

 

IntelliJ IDEA behaves quite strange.

Find in Path tool searches for `0B4C 25CF 163F 5D5E 5012 15E2 4011 CFF1 9503 B06E` instead of selected text. No matter what I do. Cursor on empty line -> CMD+SHIFT+F -> window tool likes on attached screenshot. Selected some code -> CMD+SHIT+F -> a brief moment I see something was found and then I see again like on screenshot attached. If I substitute the code with actual string - it works as expected.

At my point of view it looks like something interactively substitute search info with mentioned code.

Could you please advice how can I find out what makes this and how can I remediate it?

[UPDATE] Some additional details. IF I perform search via Menu Item -> the tool starts to behave normal even if I start it with hot keys.

[UPDATE 2] Workaround works only till IntelliJ IDEA restart.

 

Best regards,

Kostyantyn

 

IntelliJ IDEA 2018.2.5 (Ultimate Edition)
Build #IU-182.4892.20, built on October 16, 2018
Licensed to Kostyantyn Krakovych
You have a perpetual fallback license for this version
Subscription is active until September 25, 2019
JRE: 1.8.0_152-release-1248-b19 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.13.6

 

7
9 comments

Hello. Please provide idea.log after reproducing a problem.

0

Hi Petr,

I have performed next steps

  1. Closed project and then closed IntelliJ IDEA.
  2. Get rid of logs.
  3. Started IDEA and opened project.
  4. Open a class, highlighted a word with double click on it.
  5. Pressed CMD+SHIFT+F on a moment I saw correct search and then search word is replaced with mentioned 'code'.

Compressed logs are available for download via the web link https://www.icloud.com/iclouddrive/0PRwrX7MK7d7hw6uavvUXvaOg#logs-20181029-105654

 

Best regards,

Kostyantyn

1

My team is having exactly the same issue. Obviously the inserted "code" is different.

1

Hi Team,

 

In addition please check the screen video for the issue. https://www.icloud.com/iclouddrive/0nwjvXxSEAY6le26GCbakTQZg#FindInPathIssue-20181030

 

Best regards,

Kostyantyn

0

Hi Daniel,

 

Thanks for the web link. It explains a lot.

Disabled the hot key for Open PGP - now the tool works as expected.

 

Best regards,

Kostyantyn

6

Yeah, confirmed that CMD+Shift+F adds the GPG finger print for the logged in user.

To disable it:

  • System Preferences -> Keyboard -> Shortcuts -> Services -> (Uncheck the OpenGPG: Insert My Fingerprint)

Thanks!

27

What @Sposmen said helped me. This is not a problem with IntelliJ itself, but rather GPG Suite 

0

Thanks @Sposmen!

0

Please sign in to leave a comment.