No "Run manage.py task" on my Tools Menu

Answered

I'm following the instructions at https://www.jetbrains.com/help/pycharm/creating-django-application-in-a-project.html because I neglected to name my application when I was following the Django tutorial here: https://www.jetbrains.com/help/pycharm/creating-and-running-your-first-django-project.html

However, when I choose "Tools" I see no "Run manage.py task"

I thought maybe I needed to choose "Open Task" here:

But then this dialog box doesn't look to be any more helpful:

Here's my file structure as it stands now:

I'm on a 2015 Mac running OSX 10.14 (Mojave)

With the super latest Pycharm:

And Django 2.1.2

Please help.

Thanks so much!

~Bon


 

5 comments
Comment actions Permalink

Hi,

Please check Preferences | Languages & Frameworks | Django, is Django Support enabled?

5
Comment actions Permalink

Also check if there are no warnings under Preferences | Languages & Frameworks | Django. I experienced this issue because I changed the settings filename. After specifying it in the Settings option, the Run manage.py task option reappeared

2
Comment actions Permalink

Thanks! I had the same question!

0
Comment actions Permalink

I have same problem too

I Looking for Django in Preferences | Languages & Frameworks | Django 

but its not there!

how I can solve this problem guys?

0
Comment actions Permalink

@Amir1374m

Do you use PyCharm Professional?

Django is not supported by PyCharm Community.

0

Please sign in to leave a comment.