Run Configuration with Sinatra Puma

Answered

Hi,

for sinatra its seems to be difficult to run a puma server.

There is no "puma" item in dropdown in the rackup template and so no specific parameters can be added.

At the end it runs as a simple rackup start, using a more or less hard coded command:

\bin\runnerw.exe" C:\Ruby24-x64\bin\ruby.exe -e $stdout.sync=true;$stderr.sync=true;load($0=ARGV.shift) C:\Ruby24-x64\bin/rackup -o 127.0.0.1 -p 8000 config.ru 

This calls the puma.exe somewhere in background but I cannot specify to read the config file with -C path

I tried to forward this using-O in rackup but that does not work.

Is there a possibility to create a run template that is actually calling "puma -C ./config/puma.rb ? 

Second anying thing is that the run configuration forces me to provide a port and IP.. I don't want this to be forwarded to rackup with -o and -p because I define port and ip in configfile for https.

It is not rubymine's fault that puma is not reading its config file when called with rackup BUT a minimalistic template whee you can configure puma as executable i missing... in magic rails it may be but I am not using rails.

 

 

 

 

 

1 comment
Comment actions Permalink

Hello,

sorry for the delay. Have you tried using the Gem command run configuration for puma? As for the config file you can navigate to a necessary one in the Run configuration.

0

Please sign in to leave a comment.