How can I set Dapple.laf.useScreenMenuBar to true when starting IDE to debug my plugin.

Hello,

I'm developing a plugin following the gradle way, and experiencing trouble that the top menu does not respond when I click. As some topics suggest that disabling useScreenMenuBar would help, I tried add it to build.gradle file as the following:

runIde {
      jvmArgs '-Djdk.util.zip.ensureTrailingSlash=false -Dapple.laf.useScreenMenuBar=false'
}

However, this setting gave two options: 

/Library/Java/JavaVirtualMachines/jdk1.8.0_152.jdk/Contents/Home/bin/java -Dapple.laf.useScreenMenuBar=true -Didea.classpath.index.enabled=false -Didea.config.path=/Users/jo/Work/idea-projects/yobatis-idea/build/idea-sandbox/config -Didea.is.internal=true -Didea.platform.prefix=Idea -Didea.plugins.path=/Users/jo/Work/idea-projects/yobatis-idea/build/idea-sandbox/plugins -Didea.required.plugins.id=org.nalby -Didea.smooth.progress=false -Didea.system.path=/Users/jo/Work/idea-projects/yobatis-idea/build/idea-sandbox/system -Djdk.util.zip.ensureTrailingSlash=false -Dapple.laf.useScreenMenuBar=false

and the launched IDE was still using osx MenuBar which did not respond when I clicked. What is the proper way to prevent the launched IDE using ScreenMenuBar?

 

Please sign in to leave a comment.