How to get terminal path to include projects conda environment

Answered

I'm using the latest Conda distribution and latest PyCharm professional.

When I open terminal inside PyCharm (using cmd), there is no path to python.

I'd rather not add python to the global system path, what I'd like to see is that when I create a project (and conda venv) the terminal will have the correct path.

 

5 comments
Comment actions Permalink

Hi,

Not sure that I correctly understand. Do you mean that you would like to see the full path to the interpreter in the Terminal or would you like to have an environment automatically activated?

0
Comment actions Permalink

I would like to have the environment for the current project automatically activated

0
Comment actions Permalink

Then I believe it's a known issue https://youtrack.jetbrains.com/issue/PY-23417, please vote for it to increase priority and follow for updates. 

See https://intellij-support.jetbrains.com/hc/en-us/articles/207241135-How-to-follow-YouTrack-issues-and-receive-notifications if you are not familiar with YouTrack.

0
Comment actions Permalink

Thanks Sergey,

 

One other question. How do I get the proper path set? I'd like to avoid setting the global path environment (I'm in windows). When I start a new CMD terminal, python (or conda) is not in my path. 

 

C:\Users\tcsmith\PycharmProjects\itm251-content>conda
'conda' is not recognized as an internal or external command,
operable program or batch file.

 

0

Please sign in to leave a comment.