Something strange with sync files from docker

Good afternoon.

I tried to install symfony using docker volume and next command.
Windows terminal:

docker run --rm -v %cd%:/app --name symfony-image composer create-project symfony/website-skeleton .

OR powershell:

docker run --rm -v ${PWD}:/app --name symfony-image composer create-project symfony/website-skeleton .

I run this command succesfully, from cmd, visual studio code terminal from different directories.

But if I run this command from phpstorm terminal, from my phpstorm project folder, I have an error:
file_get_contents(./composer.json): failed to open stream: Stale file handle

Maybe it is something related with file description or some plugins which try to read or change file immediately. And some conflict appeared there.
I tried to exclude folder from my phpstorm project but any way had an error.

Thanks in advance


Could you please attach a screenshot of a command you've used in terminal + the output?


Probably, I found the reason, but not sure. It seems, I run my project from usb drive directly. I tried once from ssd hard drive and there everything is correct. Will try in the weekends once again. Thanks for response.


Please sign in to leave a comment.