PyCharm plugin import java class (dependency issue?)

Hi,

I've been running into the following error when using my plugin in PyCharm : `java.lang.NoClassDefFoundError: org/yaml/snakeyaml/Yaml`.

This happens even though I've added the following to my Gradle:

dependencies {
compile "org.jetbrains.kotlin:kotlin-stdlib-jdk8"
compile group: 'org.yaml', name: 'snakeyaml', version: '1.23'
testCompile group: 'junit', name: 'junit', version: '4.12'
}

How can I ensure that Pycharm would have snakeyml imported? Sidenote -  the plugin works perfectly in IntelliJ

Please sign in to leave a comment.