Worked til now - but now: no usages of private method found in one specific Project Files

Hello Forum,

when I look for usages for functions in other classes it works. When I click on the use of a private function within the class (ctrl-b - go to declaraion) - it works. When I then go on the declaration of the private methol (either alt-F7 or right-click "find usages") it says: no usages found. How can that be? When I search within the file using string search I find it. Function name is also not grey (which would mean "unused function"). Have I accidentally changed some setting?

Thx in advance,

frankxz

6 comments
Comment actions Permalink

... the supposed fault only seems to occur in one class. In another, same project, different folder, the "find usage" works within the class for private methods. For a  public method in the same class which is a public method from the inherited parent class  the usages are found too. So only the usages of the private methods within the same class are not found. Why? 

0
Comment actions Permalink

Opening and closing the file in the first place did not help. Neither copying and renaming the function and the use of the function. Tried other project files to test if "find usage" worked there (it did). Now it works again in the file where it did not work before. Why so ever could that be? Problem "gone away" but not solved ... ;-) 

0
Comment actions Permalink

1) either an issue with caches: running File > Invalidate Caches/Restart > Invalidate and Restart should help here

2) a complex usage .e.g via PhpStorm metadata and/or method chaining, or passing by reference. Next time you face this issue it would be great if you could attach classes & methods we could use to reproduce the issue

2
Comment actions Permalink

Thank you Dmitry. Class was pretty simple. Private methods of the same class. No chaining. I thought I would loose the history when deleting the cache. 

0
Comment actions Permalink

Dmitry Tronin running File > Invalidate Caches/Restart > Invalidate and Restart worked for me, for Pycharm.

Thank you!!

0
Comment actions Permalink

This didn't work for me. Still stuck with a non-fully-workingversion of PyCharm 2021.2.2 in regression with older versions...

0

Please sign in to leave a comment.