Xdebug won't work

Greetings!

So after a couple of hours trying to get Xdebug to work I'm finally reaching out hoping someone can help me to get Xdebug to work... By the way: It works perfectly with Visual Studio Code. But I'd rather use PhpStorm.

The problem: PhpStorm doesn't react to page reloads in any browser.

My system: macOS 10.14

Here's a couple of screenshots...

Xdebug Log:

Log opened at 2018-11-05 21:28:19
I: Connecting to configured address/port: localhost:9000.
W: Creating socket for 'localhost:9000', poll success, but error: Operation now in progress (19).
I: Connected to client. :-)
-> <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" fileuri="file:///Users/Steffen/Dropbox/TEST/index.php" language="PHP" xdebug:language_version="5.6.33" protocol_version="1.0" appid="7186" idekey="XDEBUG_ECLIPSE"><engine version="2.5.5"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[http://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2017 by Derick Rethans]]></copyright></init>

-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" status="stopping" reason="ok"></response>

Log closed at 2018-11-05 21:28:19

 

Any Help highly appreciated :-)

 

Best regards,

Steffen

 

1 comment

So I figured it out...

Running

lsof -nP -i4TCP:9000 | grep LISTEN

gives me

php-fpm 11225 Steffen    8u  IPv4 0xe9406922d425ce85      0t0  TCP 127.0.0.1:9000 (LISTEN)

php-fpm 11226 Steffen    9u  IPv4 0xe9406922d425ce85      0t0  TCP 127.0.0.1:9000 (LISTEN)

php-fpm 11227 Steffen    9u  IPv4 0xe9406922d425ce85      0t0  TCP 127.0.0.1:9000 (LISTEN)

So php-fpm prevented PhpStorm from getting the messages.

I changed the port in the php-config and in the PhpStorm settings, now it works like a charm.

php-config:

xdebug.remote_port=9009

PhpStorm:

After a reboot of the Webserver it works.

Best regards,

Steffen

0

Please sign in to leave a comment.