How to unset key mapped by vim plugin multiple-cursors?

I want to use the IdeaVim plugin with set multiple-cursors. However, the default key mapping of multiple-cursors conflict with my keyboard layout (Svorak A5) so that I can no longer type closing square brackets, which is a deal-breaker for using the plugin.

Basically, Alt+P is both mapped to closing bracket by my keyboard layout and (I guess) to

let g:multi_cursor_prev_key = <A-p>

by the multple-cursors plugin. In regular vim (i.e. in my shell) this is not a problem because Alt+P behaves differently in insert mode (bracket) and normal mode (multiple-cursors mapping), but in GoLand the plugin overrides the keyboard layout. I have tried to unset the mapping by

let g:multi_cursor_prev_key = <Nop>

but it does not work. Any help on this would be much appreciated!

4 comments
Comment actions Permalink

Vim unmapping via `:unmap` is not supported yet, feel free to vote for https://youtrack.jetbrains.com/issue/VIM-1491. You can map `A-n>` to `<Nop>` via `:map <A-n> <Nop>`, but I'm not sure that this will free up `]` for your keyboard layout.

1
Comment actions Permalink

I don't know how it happened, but the issue disappeared and I can no longer reproduce the error.

Thanks for your help though! Btw, I voted for the unmap feature since I think it could be useful for debugging, like you state in the description.

0
Comment actions Permalink

Now the problem came back, but for Alt-N instead of Alt-P (which is also mapped by the same plugin), in both GoLand and PhpStorm (which makes sense since they both read from `~/.ideavimrc`). I don't have time to dig further unfortunately and will just disable the plugins.

0
Comment actions Permalink

See also the discussion here https://youtrack.jetbrains.com/issue/VIM-1531 for possible ideas.

1

Please sign in to leave a comment.