Path to certificate


I'm using Beanstalk (remote SVN/GIT serverI to store local files from PHPStorm on that server.

On comiting files I got a popup:


Authentification realm: https://...

Path to certificate: <empty>

Certificate passphrase


What the heck is that and how can I disable that to just commit files to the remote server?



Could you please share a screenshot with this message? What type of server are you using -- GIT or Subversion?



Sorry, if that was not clear: I'm using Subversion.

Sure, see attachment of the screenshot. It goes like that:

  1. I want to commit a file or directory
  2. I'm asked to enter username/pw for the remote repository (even tough Save Credentials is checked I have to enter it all the time)
  3. Then this Authentification screen pops up (attachment)

Beanstalk told me to empty to clear the Auth Cache what I did (restart of PHPStorm included). Since a mess up in PHPStorm I was forced to completly recreate the remote repository (from scratch). Now/since then this Auth message pops up when I try to access the remote repository.




Please check that your Network Options in Preferences | Version Control | Subversion | Network > Edit Network Options are clear (no files specified).

What are your authentication options for this server? 

You might want to submit this to our tracker + attach IDE logs to investigate this in details: We already have some related issues submitted:,, & others.


I've checked it, all empty (as it should)

The remote SVN service (Beanstalk) wants a username and password and offers a https link to my remote SVN. Simple as hell. I've already asked them and they have no clue why it shouldn't work from PHPStorm. In the past it worked well and after an update PHPStorm started to screw up remote SVN so that I was forced to drop and recreate the remove SVN to make it as easy as possible to PHPStorm but still nothing works.

Now, I wanted to start from scratch and create a new SVN remote repository based on the manual in PHPStorm: -> Unclear to me where the "SVN Repositories tool window " should be, didn't find it menu Tools nor in VCS menu, nor in preferences...

Clicking on SVN Repositories tool window I would expect to show me HOW TO GET THERE but it just shows me the commands... 

Toolbar activated but also not there...

When I activate local SVN (by menu VCS) and then try to import or export from remote repository (which seems to be the only place to define/connect to a remote repository) I get other erros:


Whatever that means... I'm just clueless I only want to use an external SVN repository, thats all. Seems I'm asking for too much.

And no, I will not waste more time to create a ticket. I've already created some and are still not resolved (some even simpler stuff than this). I'm soooo tired and soooo  sick about all that.... 




-> I'm not using Smartcards. I just wanna use a remote SVN directy of which I'm the owner

-> Reminds me another bug: I ALWAYS have to enter my credentials when accessing my remote SVN even tough "save credentials" is checked all the time

-> Yes, that comes closest to the current problem. That entry is 5 years (!) old, not resolved yet and you want me to create another ticket? 



I am using IntelliJ 2019.1. After updating to the latest version 2019.1.3 all of the sadden I am getting this annoying popup with "Path to certificate" and "Certificate passphrase". 


Some of those issues are still not addressed unfortunately: &

It would be great if you could submit the issue you're experiencing to our tracker at


Please sign in to leave a comment.