WebStorm React Native debugging 'very flacky'

Answered

Hi,

As described in docs, I run first my app with 'react-native run-ios'. Later defined a debug configuration for iOS which start the bundler.

Using the debug configuration, I am not consistently able to run the debugger and stop at breakpoint.

1) Anyone having same problem (I am using  2018.2)?

2) Any advice on proper sequence of steps?

Thanks

 

5 comments
Comment actions Permalink

Please provide more details:

  1. What is your React Native version?
  2. Do you use Expo?
  3. What exactly happens when you aren't able to run debugger? Is there any error?
  4. How does your run/debug configuration look like?

Also see https://blog.jetbrains.com/webstorm/2016/12/developing-mobile-apps-with-react-native-in-webstorm/

0
Comment actions Permalink

HI Oksana

More info:

- React native version: "0.57.4"

- No I don't use expo

- Sometime I get 'unknown ios error' however the app appears and behaves ok but the debugger does not stop at breakpoint.

- Please see configuration in snapshot 

Many thanks

0
Comment actions Permalink

Thank you for the details!

Could you please check if the issue is reproducible for you in 2018.3 (https://www.jetbrains.com/webstorm/nextversion/)? It includes a fix of the issue with this React Native version.

0
Comment actions Permalink

Hi Oksana 

I tried 2018.3 but did not make a difference... it seems that I am forced to use Visual Studio Code as other team members. It is a pity because I use, and I like,  Android Studio to build android and Flutter mobile apps. 
 
In case I am doing something wrong please send me the correct steps of operations I need to do in order to debug properly.
 
Cheers
0
Comment actions Permalink

Sorry to hear that.

Are you able to reproduce the problem in a brand new react native project? Or is it possible to provide us with a project you encounter the issue with?

Could you please provide your idea.log.* files (please don't paste their contents here. If you don't want to provide them publicly, please upload them in an archive to ftp://ftp.intellij.net/.uploads/ and let me know its name).

Also, attach a screenshot of `Start React Native Bundler` section in your run/debug configuration.

0

Please sign in to leave a comment.