Markdown Support plugin preview not working in Linux

Answered

I have installed the Markdown Support plugin Version: 182.4129.4 in pycharm community edition version 2018.2.4-1 on Manjaro Linux running 4.19.1-1-MANJARO kernel.

I am able to edit the .md file but I am unable get the preview of it. On checking the Markdown option in the Languages & Frameworks tab in the Settings, it shows 'There are no available preview providers'.

I have been able to reproduce this bug on the previous two versions of pycharm and the plugin too. I have no problem in the Windows 10 counterpart. The plugin works fine in Windows 10 even in previous version of pycharm and the plugin.

10 comments
Comment actions Permalink

Please can you provide your idea.log (https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files)? Don't paste it here, upload it to some file server and provide a link

0
Comment actions Permalink

Most likely the JRE you run PyCharm with (Oracle 1.8.0_192-b26) doesn't include javaFX; can you check if the issue persists when using the bundled JDK? See https://intellij-support.jetbrains.com/hc/en-us/articles/206544879-Selecting-the-JDK-version-the-IDE-will-run-under for instructions on switching IDE JDK

0
Comment actions Permalink

Thank you! I found the solution.

The default bundled JRE with Pycharm on my system was the Oracle 1.8.0_192-b26, which did not work, the other JRE installed by default on my linux system was the JAVA-8-open-JDK which also did not work.

What worked for me was installing the Oracle 1.8.0-192 JRE from the oracle website and using it as my JDK on Pycharm.

0
Comment actions Permalink

>The default bundled JRE with Pycharm on my system was the Oracle 1.8.0_192-b26, which did not work

PyCharm doesn't bundle Oracle JRE, it bundles custom JRE provided by JetBrains, and it definitely includes javaFX...

Anyway, nice to hear you've solvbed the problem:)

0
Comment actions Permalink

I'm sorry, on further checking I found that the bundled jdk is not the one I mention in earlier post, but the build number of the bundled jdk is the same as the one I was previously using i.e. 1.8.0_192-b26, which did not work for some reason.

The one which worked for me had a different build i.e Oracle 1.8.0_192-b12

0
Comment actions Permalink

Thank you; I'm using OpenJDK Runtime Environment 18.9 (build 11.0.1+13), and there's no preview or even toolbar. I'll use Atom to edit my Markdown.

0
Comment actions Permalink

Hi Brian,

You can try ensuring that PyCharm is running with the bundled JDK by selecting it according to: https://intellij-support.jetbrains.com/hc/en-us/articles/206544879-Selecting-the-JDK-version-the-IDE-will-run-under

The easiest way - define `PYCHARM_JDK_64` environment variable and point it to `jre64` directory inside your PyCharm installation path.

Of course, using Atom is also a viable option.

0
Comment actions Permalink

Simply install OpenJFX and restart IntelliJ

$ sudo apt-get install openjfx

See: https://stackoverflow.com/questions/18547362/javafx-and-openjdk

NOTE: In some case, Oracle JDK is not an option (due to their latest licence changes). OpenJDK can still be used with OpenJFX, without having to compile anything.

3
Comment actions Permalink

G Lafond's answer worked for me

2

Please sign in to leave a comment.