Markdown Support plugin preview not working in Linux


I have installed the Markdown Support plugin Version: 182.4129.4 in pycharm community edition version 2018.2.4-1 on Manjaro Linux running 4.19.1-1-MANJARO kernel.

I am able to edit the .md file but I am unable get the preview of it. On checking the Markdown option in the Languages & Frameworks tab in the Settings, it shows 'There are no available preview providers'.

I have been able to reproduce this bug on the previous two versions of pycharm and the plugin too. I have no problem in the Windows 10 counterpart. The plugin works fine in Windows 10 even in previous version of pycharm and the plugin.


Please can you provide your idea.log ( Don't paste it here, upload it to some file server and provide a link


Most likely the JRE you run PyCharm with (Oracle 1.8.0_192-b26) doesn't include javaFX; can you check if the issue persists when using the bundled JDK? See for instructions on switching IDE JDK


Thank you! I found the solution.

The default bundled JRE with Pycharm on my system was the Oracle 1.8.0_192-b26, which did not work, the other JRE installed by default on my linux system was the JAVA-8-open-JDK which also did not work.

What worked for me was installing the Oracle 1.8.0-192 JRE from the oracle website and using it as my JDK on Pycharm.


>The default bundled JRE with Pycharm on my system was the Oracle 1.8.0_192-b26, which did not work

PyCharm doesn't bundle Oracle JRE, it bundles custom JRE provided by JetBrains, and it definitely includes javaFX...

Anyway, nice to hear you've solvbed the problem:)


I'm sorry, on further checking I found that the bundled jdk is not the one I mention in earlier post, but the build number of the bundled jdk is the same as the one I was previously using i.e. 1.8.0_192-b26, which did not work for some reason.

The one which worked for me had a different build i.e Oracle 1.8.0_192-b12


Thank you; I'm using OpenJDK Runtime Environment 18.9 (build 11.0.1+13), and there's no preview or even toolbar. I'll use Atom to edit my Markdown.


Hi Brian,

You can try ensuring that PyCharm is running with the bundled JDK by selecting it according to:

The easiest way - define `PYCHARM_JDK_64` environment variable and point it to `jre64` directory inside your PyCharm installation path.

Of course, using Atom is also a viable option.


Simply install OpenJFX and restart IntelliJ

$ sudo apt-get install openjfx


NOTE: In some case, Oracle JDK is not an option (due to their latest licence changes). OpenJDK can still be used with OpenJFX, without having to compile anything.


G Lafond's answer worked for me


Anyone know how to install OpenJFX on MacOS? No homebrew cask available. Can't find install instructions anywhere; perhaps not a good solution for Mac.


I fixed this under manjaro by installing java8-jfx


Please sign in to leave a comment.