Monospaced wrong rendering when Windows scalling is turned on.

Answered

I have Full HD on 15'' laptop. So my system scaling is turned on to 125%

And I have a wrong rendering of Monospaced

If I turn normal scaling to 100% it looks OK for me 

It seems like font scales only in horizontal

That appears only in Editor

 

How can we fix it with scaling turned on?

I run Windows 10 last updates, IntelliJ 2018.2.5 release version on bundled JDK

 

UPD: If I run IntelliJ in compatibility mode with override DPI option to System I have normal fonts, but with a dramatic loss of sharpness 

17 comments
Comment actions Permalink

No, nothing new the font is still weird.

I restarted IntelliJ after applying VM arguments you suggested
 

1
Comment actions Permalink

Still the same 

1
Comment actions Permalink

How I can help you to get it fixed?

1
Comment actions Permalink

Sorry being annoying but this bug disturbs me every time I code.
Any news or thoughts on that?

1
Comment actions Permalink

2020.1 isue is still present

1
Comment actions Permalink

Sounds like https://youtrack.jetbrains.com/issue/IDEA-185238

Does it help if you set sun.java2d.uiScale.enabled=false property in vmoptions?

0
Comment actions Permalink

Please check if the problem reproduces at 2018.3:

https://www.jetbrains.com/idea/nextversion/

0
Comment actions Permalink

I have the same problem with a 27" 2k monitor. System scaling is 125%.

The property sun.java2d.uiScale.enabled=false doesn't help.

0
Comment actions Permalink

Could you please run "Change display settings" from the system config and see if there's a warning like "Some apps won't respond to scaling changes until you sign out". And if it is, please sign out/in. Then please try running IDEA with -Dsun.java2d.uiScale.enabled=true and then 'false'. Please also attach idea.log in both the cases. Does it make any difference?

0
Comment actions Permalink

Petr Rastegaev,

There were no warning messages, but I've signed out/in just in case.

I can't attach logs. I can't attach anything except images.

I've tried both true/false, and nothing changes at all.

I've checked the link, and it is correct, fonts are same (as far as I can tell).

But, what does it means for me? It is still doesn't looks like it without (or system) scaling.

Scaling set to 125%:

Scaling set to 100%:

0
Comment actions Permalink

Hello.

Sorry for the delay, could you please try 2019.1 EAP, some scaling issues were fixed there:

https://www.jetbrains.com/idea/nextversion/

0
Comment actions Permalink
Can this issue be given a bit higher priority?
I am using a 15" Notebook with a high-resolution display (3840x2160) especially because I want sharp text for coding.
This ugly font rendering makes IntelliJ IDEA and PyCharm unusable for me.
I have attached images to compare the font rendering of IntelliJ and Visual Studio Code (both using the same font - FiraCode Retina).
 
0
Comment actions Permalink

I have exactly the same font issue on windows 10 and external fullHD monitor with 125% scaling. None of the posted solutions helped. I can attach screenshots, but they looks same to topicstarter ones.

 Will any fix be available soon? I have this bug in latest PHPStorm, Intellij IDEA, Android Studio.

0
Comment actions Permalink

Please provide idea.log
Also, does using -Dsun.java2d.uiScale.enabled=false VM option change the font rendering for you?

0
Comment actions Permalink

Please see https://intellij-support.jetbrains.com/hc/en-us/articles/360007994999 for the scaling options you can use that may help to workaround the problem.

0

Please sign in to leave a comment.