Package requirements not satisfied (though they are)

Answered

I'm using pipenv, and my virtual environment is located in /Users/kdm/.virtualenvs/current_tracker-e-AzFSGN/lib/python2.7/site-packages.  That's where I've told PyCharm the project interpreter is located.

 

If I issue pip list, I get:

(current_tracker-e-AzFSGN) McKenzie-Mac:current_tracker kdm$ pip list
Package Version Location
----------------------------- ---------- ---------------------------------------------------------------------
alembic 1.0.2
amqp 2.3.2
astroid 1.6.5
Babel 2.6.0
backports-abc 0.5
backports.functools-lru-cache 1.5
billiard 3.5.0.4
celery 4.2.1
certifi 2018.8.24
Click 7.0
configparser 3.5.0
coverage 4.5.2
dominate 2.3.4
enum34 1.1.6
Flask 1.0.2
Flask-Bootstrap 3.3.7.1
Flask-Migrate 2.3.0
Flask-Moment 0.6.0
Flask-SQLAlchemy 2.3.2
flower 0.9.2
futures 3.2.0
isort 4.3.4
itsdangerous 1.1.0
Jinja2 2.10
kombu 4.2.1
lazy-object-proxy 1.3.1
linecache2 1.0.0
Mako 1.0.7
MarkupSafe 1.1.0
mccabe 0.6.1
pip 18.1
pipenv 2018.10.13
pylint 1.9.3
pylint-flask 0.5
pylint-plugin-utils 0.4
python-dateutil 2.7.5
python-editor 1.0.3
pytz 2018.7
setuptools 40.4.3
singledispatch 3.4.0.3
six 1.11.0
smpe-list-parser 0.1.0 /Users/kdm/.virtualenvs/current_tracker-e-AzFSGN/src/smpe-list-parser
SQLAlchemy 1.2.14
tornado 5.1.1
traceback2 1.4.0
typing 3.6.6
unittest2 1.1.0
vine 1.1.4
virtualenv 16.0.0
virtualenv-clone 0.3.0
visitor 0.1.3
Werkzeug 0.14.1
wheel 0.32.1
wrapt 1.10.11
xmlrunner 1.7.7

 

However, pycharm is also telling me that a number of requirements from Pipfile.lock aren't satisfied:


I'm not sure how to resolve this.

This is with

PyCharm 2018.2.4 (Professional Edition)
Build #PY-182.4505.26, built on September 19, 2018
Licensed to Kevin D McKenzie
Subscription is active until April 10, 2019
JRE: 1.8.0_152-release-1248-b8 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14

2 comments
Comment actions Permalink

Hi Kdm,

All these packages are listed in Project Interpreter settings, right?

Please try to remove this interpreter from IDE, then do File | Invalidate Caches/Restart.. | Invalidate and Restart and add the interpreter again. Wait for IDE to finish updating stubs and check again.

0
Comment actions Permalink

That did it, thanks.

0

Please sign in to leave a comment.