External tools - result is printed into console instead of file

Some time ago I configured an external remote tool for making a DB backup:

mysqldump -h xxx -u xxx --password=xxx --databases xxx > backup_$(date +%Y-%m-%d-%H.%M.%S).sql

Everything worked fine. Today I tried to run such command and IDE printed all output to the console. Running that command directly from command line works fine. Last time when I ran that tool from IDE it also worked fine. It was on 2018-08-03.

Has something changed since then or it's a bug?

My current IDE version is: 2018.2.5

On that time I've got latest stable version of phpStorm (not EAP) but I can't remember numbers.

Comment actions Permalink

You can create a bash script that runs your command, and configure this script as external tool

Comment actions Permalink

Wrapping arguments line with quotes caused another error:

ssh://x@ "-h xxx -u xxx --password=xxx --databases xxx > backup_$(date +%Y-%m-%d-%H.%M.%S).sql"
Usage: mysqldump [OPTIONS] database [tables]
OR     mysqldump [OPTIONS] --databases [OPTIONS] DB1 [DB2 DB3...]
OR     mysqldump [OPTIONS] --all-databases [OPTIONS]
For more options, use mysqldump --help

Without quotes command runs fine, but with output to console. Unfortunatelly it looks like server doesn't allow to quoting arguments in this case.


Please sign in to leave a comment.