Compilation terminated with error on unknown file

Answered

 

Here when i compile my adobe air application i am getting errors on a file that not exist in my project library. The file name is 

{myprojectname}_Styles.as and the error is Error code: 1084: Syntax error: expecting rightparen before s.

the same error is reported on some other not existing file also. How can i get out of from the issue. 

 

IDE details.

 

14 comments
Comment actions Permalink

Hello,

Is it possible to provide sample project example for investigation?

0
Comment actions Permalink

This is a client project and i am not permitted to share this. But this project is working fine in another PC's

0
Comment actions Permalink

Is it reproducible with new sample project?

0
Comment actions Permalink

As far as I understand, Flex compiler generates Foo_Styles.as file in memory during the compilation of Foo.as (or Foo.mxml). So I suggest to check Foo.as (Foo.mxml) file and play with its sources to detect which parts affect these error messages.

0
Comment actions Permalink

@Alexander Doroshko 

Ya i have a file like this foo.mxml . But even if i have commented all the contents from that file . this error occurs again 

0
Comment actions Permalink

I can check your project structure if you attach .idea folder  + all *.iml files zipped.

Or I can check the whole project if it is possible to attach a sample project where the issue can be reproduced.

If you can't attach anything I'd suggest to try to bisect the problem. As soon as you have a project where the problem occurs and a project where it doesn't, modify one of them (or both) to catch the moment when the problem appears (or disappears). The clue should be either in code or in the project setup.

0
Comment actions Permalink

here is my .idea folder https://drive.google.com/open?id=1tfHK66zlpBic96OV8pobXQevq1xYBxna  

iml files  : https://drive.google.com/open?id=14EZX3JZmMCYfg0dxToTUzl4gOBwIFi3c

 

 

The same code is working on some other pc's but the problem occurs in my pc only

0
Comment actions Permalink

It looks like .idea folder and iml files are from different projects. 

.idea/modules.xml file contains a reference to one module file called HomeWAV.iml but you've uploaded 2 different iml files: flash.iml and Myproject.iml. Please attach HomeWAV.iml.

0
Comment actions Permalink

Thanks,

  • So first of all, make sure that the SDK that is called 'air_30' in your IDE installation is a valid Flex+AIR SDK installation. You may paste a screenshot of its roots here and I'll double-check (Project Structure | Modules | HomeWAV module | HomeWAV build configuration subnode | Dependencies tab). Or you may try reinstalling the Flex+AIR SDK from scratch or using a different existing Flex+AIR SDK installation on your computer.
  • Next, it's rather strange that you have configured 3 different mx.swc files as dependencies for your build configuration ($PROJECT_FRAMEWORKS$/frameworks/libs/mx/mx.swc, Flex SDK v4.15-16-16/frameworks/libs/mx/mx.swc and I:/sdk's/air_30/frameworks/libs/mx/mx.swc). Normally you don't configure any of mx.swc files manually. And since your build configuration is targeting Mobile platform, mx.swc is probably not needed at all.
  • The rest looks good.
0
Comment actions Permalink

 

 

In my app i need one mx.swc (I:/sdk's/air_30/frameworks/libs/mx/mx.swc) to import some packges. I have removed other two.

0
Comment actions Permalink

The screenshot would be more interesting if the SDK node was expanded, but I guess everything is fine there.

I'll be able to help further only if I manage to reproduce the problem in my environment. So far I failed to. So the best thing I can suggest is to create a copy of the project and remove parts of it until the problem disappears, thus trying to find the root cause.

0
Comment actions Permalink

I have tried the same in another pc and it is working. and i am ok with it. Anyway thanks for your help and time.

0
Comment actions Permalink

I tried to open the google drive which is provided in this post but I am getting Google drive server error and can't able to find out the solution regarding this kind of error. Any suggestions in this matter?

0

Please sign in to leave a comment.