After update to Webstorm 2018.3 - Node debug connector error

 So, after this update, when I try to debug my node app using node 10.1.0 that used to work ok with 2018.2,  this error comes up:

Debugger attached.
Error in JetBrains node debug connector: TypeError: Cannot read property 'port' of null
at Object.<anonymous> (/private/var/folders/3k/54pjx4d56lxgq1k9hf0gggnr0000gn/T/debugConnector.183.4284.130.js:9:28)
at Module._compile (internal/modules/cjs/loader.js:678:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:689:10)
at Module.load (internal/modules/cjs/loader.js:589:32)
at tryModuleLoad (internal/modules/cjs/loader.js:528:12)
at Function.Module._load (internal/modules/cjs/loader.js:520:3)
at Module.require (internal/modules/cjs/loader.js:626:17)
at Module._preloadModules (internal/modules/cjs/loader.js:781:12)
at preloadModules (internal/bootstrap/node.js:555:7)
at startup (internal/bootstrap/node.js:216:9)

Nothing was changed in the Run configuration. No node options provided.
Tried adding  "--inspec" and "--inspect-brk"  to no avail.

Couldn't find any pointer to solve this issue on this forum or on the net.

Thanks!

10 comments

https://youtrack.jetbrains.com/issue/WEB-35630 is fixed in 2018.3.1

As a workaround try disabling js.debugger.use.node.options key in Registry ( Help | Find action, type Regisry to locate it) 

1

Perfect! The workaround worked as expected putting the error away.

I'll re-enable once I get 2018.3.1 in the toolbox, to see if it got fixed.

As of now the latest is 2018.3.

Thanks a lot!

1

I have the same issue with intelliJ IDea latest version,

on Mac OSX, how can this be solved?

 

0

What IDEA build do you use? Also, does disabling js.debugger.use.node.options key help?

1

Hi

 

Where should we put the js.debugger.use.node.options ?

We're using IDEA 2018.3.1

 

 

 

0

What should be done for Mac ? there is no registry like windows.

-1

It's the IDE registry, not OS one. You can use Help | Find action to locate it, just as it's written in my comment: https://intellij-support.jetbrains.com/hc/en-us/community/posts/360001720380/comments/360000252300

1

Thanks, the work around works :)
we're able to debug -)

It's also possible to use this short cut to get to the registry on MAC OSX:

CMD / ALT / ShiFT - /


 

2

Fine, thanks for letting me know:)

Note that we've made another fix that will hopefully help, it will be included in 2018.3.3 - see https://youtrack.jetbrains.com/issue/WEB-35630#focus=streamItem-27-3233541-0-0

1

Please sign in to leave a comment.