Terminal doesn't work in PhpStorm 2018.3 (Ubuntu 18.04.1 LTS)

After upgraded to 2018.3 today, I can no more use Terminal in PhpStorm. Anyone have the same problem? How can I fix it?

 

 

17 comments
Comment actions Permalink

Hi, I have the same problem on Linux Mint 19 Tara. Fix it please

0
Comment actions Permalink

What shell path do you have at File | Settings | Tools | Terminal?

Please restart PhpStorm, try to open Terminal and check if there are any errors in idea.log file (Help > Show log in ...). If you're not sure about the errors - feel free to share the log.

0
Comment actions Permalink

Hi Dmitry, I've submit a bug in Youtrack and sent the log files here: https://youtrack.jetbrains.com/issue/WI-44357

0
Comment actions Permalink

There is a similar issue for IDEA: https://youtrack.jetbrains.com/issue/IDEA-202821
Anyone who is having the same problem can try this workaround: https://youtrack.jetbrains.com/issue/IDEA-202821#focus=streamItem-27-3177023-0-0 (though it doesn't help me out)

0
Comment actions Permalink

Same problem in PyCharm. It shows bash-3.2 ... and didn't work. 

0
Comment actions Permalink

Linxinmin, what exact PyCharm version are you running? It should've been fixed in 2018.3.2.

If it's not for you, what shell path do you have set at Settings | Tools | Terminal?

0
Comment actions Permalink

Hi Eugene, 

I've checked again. It shows "bash-3.2" when I upgraded to PyCharm 2018.3.2. And when I downgraded to 2018.3.1, the terminal worked well. 

I use the default one "/bin/bash".

1
Comment actions Permalink

Linxinmin, could you please clarify that: " It shows "bash-3.2" when I upgraded to PyCharm 2018.3.2"? Or attach a screenshot.

Are you on OS X or linux?

Could you please restart IDE, reproduce the problem and upload somewhere the idea.log file (Help > Show log in ...)?

0
Comment actions Permalink

I am on MacOS Mojave 10.14.2. 

[log has been removed]

0
Comment actions Permalink

Please attach a screenshot of Preferences | Tools | Terminal.

Try to use /bin/bash as a Shell path there.

0
Comment actions Permalink

Hi @Dmitry, 

It has been set to /bin/bash already. 

0
Comment actions Permalink

Please check if disabling Shell Integration helps.

Regardless of the results, please share them alongside with the logs and screenshots to the issue tracker:

https://youtrack.jetbrains.com/newIssue?project=IDEA

 

0
Comment actions Permalink

@Linxinmin the issue yo referred to is unavailable =(

Previously my terminal was working nice with syntax highlight and autocomplete. But when I upgraded to Pycharm 2018.3.2 it started to behave like reported above:

I have literally changed nothing, just the update. 
I use Mac OS X 10.13.6

0
Comment actions Permalink

@Portela I set the ticket only visible to the Pycharm Team I think.

The issue has been resolved in 2018.3.3. The developer has sent me the build and the new version works well.
It was similar to an old issue.

1
Comment actions Permalink

The issue was caused by https://youtrack.jetbrains.com/issue/IDEA-201459

Workaround: disable "Python Terminal" plugin.

0
Comment actions Permalink

I can confirm that version 2018.3.3 has solved the issue. Thank you @Linxinmin !

0

Please sign in to leave a comment.