Force PHPStorm to use *remote* Behat interpreter

I configured remote behat interpreter on docker (phpstorm recognises remote php and behat versions correctly) however when I try to run the test (or create test configuration) I always keep getting, "Error: Path to Behat for local machine is not configured".  Well, I know it's not configured because I want to use the *remote* one. How do I force behat test to run in the remove environment -- I can't see that option in Run/Debug configurations.

1 comment
Comment actions Permalink

1) you need to make sure remote CLI Interpreter is selected at File | Settings | Languages & Frameworks | PHP

2) add "Behat by remote ..." config at File | Settings | Languages & Frameworks | PHP | Test Frameworks:

This should help

0

Please sign in to leave a comment.