Turn off automatic 'read-only' conversion of Java to Scala

Answered

In my .java files, Intellij will show parts of the java code as scala code.    

... However, the code isn't actually changed; if I double-click on an area that's been visually converted, it will show the actual Java code.  So in the end, I have this half-java, half-scala code and it's unreadable and confusing. 

I have searched many times in vain to find what causes this.  Any 'how to turn this off' settings clues would be greatly appreciated!

 

2 comments
Comment actions Permalink

Looks like you mean the IDE folding feature and may be using additional plugins for it, like Advanced Folding

To disable certain types of folding, go to Settings | Editor | General | Code Folding.
0
Comment actions Permalink

/me weeps softly

 

Thank you so much.

0

Please sign in to leave a comment.