control function keys (e.g. "cntrl F" for find) stop working


I need help fixing this.  Most key coimbinations that start with control key such as Control X, Control Z, Control D, Control F, etc. suddenly stop working.  There is nothing wrong with keyboard since the same combination works fine on other application.

Not sure what caused it. 




Please check if these shortcuts are assigned to actions in your Settings/Preferences | Keymap. Try setting it to default scheme.

If everything seem to be correct in Keymap settings, please rename/remove configuration folder to start with defaults


Hi Sergey, 

The shortcuts are defined in settings/keymap (though somewhat different from before, e.g. delete line was ctrl+X, now it is ctrl+Y. But that's is ok.

I renamed the config folder, restart the computer and start pycharm.  a new config folder was created.   But nothing's changed.  For instance the shortcut for find (defined in keymap as ctrl F), just jumps around.   What else can I try?

This problem happened very suddenly.  I couldn't figured out what the cause could be. 


I just realized that I did update perl plugin very recently.  So I tried disable it and that does the job!



I know it is an old issue, but wanted to highlight it because I had a similar issue. When using cmd + F, the "enter" button did not move to the next occurrence of the found string, it just stod still.

Disabling the Makefile plugin that I just installed was the culprit, and removing it solved my issue.  


Time to time Intellij Idea refuses to react to ALL hotkeys. Only restart helps.



IntelliJ IDEA 2023.3.3 (Ultimate Edition)
Build #IU-233.14015.106, built on January 25, 2024
Licensed to <me>
Subscription is active until February 17, 2024.
Runtime version: 17.0.9+7-b1087.11 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Linux 5.10.0-27-amd64
GC: G1 Young Generation, G1 Old Generation
Memory: 8192M
Cores: 12
Non-Bundled Plugins:
 com.4lex4.intellij.solarized (2.4.0)
 com.intellij.plugins.xwinkeymap (211.4961.30)
 com.jetbrains.CyanTheme (1.3)
 com.perl5 (2023.3)
 com.mroche.JsonHelper (1.3.2)
 org.jetbrains.plugins.spotbugs (1.2.7)
 String Manipulation (9.12.0)
 com.jetbrains.packagesearch.intellij-plugin (233.11799.196)
 net.seesharpsoft.intellij.plugins.csv (3.2.3-233) (233.14015.106)
 io.plugin.tsnode (2022.11.14-1)
 Pythonid (233.14015.106)
 org.exbin.deltahex.intellij (0.2.9)
 aws.toolkit (2.5-233)
Kotlin: 233.14015.106-IJ
Current Desktop: XFCE


Please sign in to leave a comment.