Webstorm not opening up page in Chrome when debugging

Hello,

I am running Webstorm 2018.3 on Windows 10 and using Chrome Canary 72.0.3623.0 64-bit. Recently, when I try to debug webpages with clientside JS, Chrome opens, but the webpage doesn't load. It also says that it can't connect to the JetBrains Chrome extension despite the extension reporting that its connecting to WebStorm. This works fine on macOS with the same version of Chrome Canary and Webstorm.

How can I fix this issue?

6 comments
Comment actions Permalink

Most probable reason of such issues is a network configuration that blocks connections on this port/localhost/etc. Does your network traffic go via proxy? Can you provide your idea.log (https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files) along with the JetBrains IDE extension console content (http://confluence.jetbrains.com/display/WI/LiveEdit, How do I know what's wrong?)? Please don't paste logs content here, upload them to some file server and provide a link.

Also, can you check if debugging works without extension (Use JetBrains IDE Support extension for debugging and Live Edit disabled in Settings | Build, Execution, Deployment | Debugger | Live Edit)?

1
Comment actions Permalink

Got the same problem, but in 2020.  Tried activating the live edit for all file types, not just HTML and CSS, still not working.  Help!  This happened suddenly, right around the time I updated Webstorm.  Could there be a bug in the update?

0
Comment actions Permalink

Are you using Chrome extension? It doesn't work reliably in most recent Chrome versions (https://youtrack.jetbrains.com/issue/WEB-37230), and we recommend turning it off in Settings | Build, Execution, Deployment | Debugger | Live Edit, Use JetBrains IDE Support extension for debugging and Live Edit

0
Comment actions Permalink

Yep chrome, but the same is true for other browsers i tried ( opera, ie, Firefox does not load at all and gives a crash message). This is definitely a problem that started the moment I updated webstorm. Can you look into it?

0
Comment actions Permalink

Debugging is only supported in Chrome, so I'm not sure what problem you are talking about...

0
Comment actions Permalink

I add presumably the same issue e.g Chrome not opening the URL setup inside the "Javascript Debug" configuration.

Thanks to Elena Pogorelova's previous suggestion I found out that enabling the following option solved my issue:

Settings | Build, Execution, Deployment | Debugger | Allow unsigned requests

0

Please sign in to leave a comment.